Twinmotion smooth normals

I’ve got a high poly model and import it straight to Twinmotion with import button. But edges are not smoothed. Who knows how to solve it?

You might want to try more segments in your original SKP model. Not sure how many you used, but at least 60 or more should get a smooth surface in TM. I am also assuming you have “smooth or soften edges” already in the SKP model?

Also check that you don’t have a “low” quality display setting in TM preferences.

I have also had issues with SKP surfaces displaying as segments in TM, but at the smaller scale…say around 3" diameter, even with 24-48 segments.

I gave up on the SKP to TM direct import link, and now use .OBX files exported out of SKP, then sync the Imported .OBX in TM after any changes made back at the original SKP model. I think there still are some issues with the SKP link, and maybe a graphic card deal too, so .OBX seems to cure the segment issue, (at least in my case).

Sorry…meant to say… ".OBJ " file, or even try .FBX format too