Trouble with line tool following axis

Hey guys, sorry for the noob question, but I recently switched from Mac to Windows and I’m currently still working out the kinks.

It seems when I use the line tool to lets say draw a straight line in the middle of the model it will only snap parallel to blue and red axis, not the green. So if I start a line 1’ out from the green axis, and draw it say, 10 feet, the end point will touch the green axis instead of keeping it 1’ away just like the start point. Thus I can only draw diagonal lines to the green axis.

The only way around this is if I start drawing from the corner origin. Never had this problem in mac. If I wanted to draw a kitchen for example, I could start with the island and it would be square to all 3 axis. No need to start from the corner out, or set a origin every time I open a new project.

Feel like a caveman with this one. Thanks for the help

Maybe you just need to change the camera position a little by orbiting. Or you could force the tool into the green direction by hitting the left cursor key.

I’ve never had any sort of problems with either PC or Mac like you are reporting so I’m thinking that’s a red herring.

Ok just captured it, sorry for not editing, wanted to get it up quick.

Hitting Left and holding Shift doesn’t not work. Should I consider reinstalling?

Is the camera set to Parallel Projection? Make sure it is set to Perspective.

Don’t do that. Click and release to start the line, tap and release the left Arrow key and move the mouse. Don’t push any other buttons.

I doubt this particular thing has anything to do with installation but when you installed SketchUp did you right click on the downloaded installer and choose Run as administrator or did you simply double click on it? If you didn’t use Run as administrator from the context menu, do that now and repair the installation.

Not sure, I will try later tonight when I have time and get back to you. Thanks for your prompt responses!

1 Like

Tried to repair as Admin, did not fix it. :unamused:

Did you check the camera setting and try changing the camera position with Orbit?

I sent you a PM.

It looks like you managed to snap to the green line fine in your video, that looks normal to me. Are you confused that it looks like it is not parallel to the green axis because you’re in perspective view? It looks like its almost touching the green axis as you look at something infinitely far away. Maybe you’ve changed the camera’s field of view. Go to Camera Menu -> Field of view and set it to 35°. The field of view in your video looks normal to me though.

How long did you use SketchUp on the Mac before you switched to windows?

I think you and Dave are right. Everything seems to be fine, just dealing with a massive optical illusion on my end. I didn’t use Sketchup enough apparently haha. I did manage to draw some plans for some renovation projects.

Just really baffles me why this is happening now and not on my mac.

Check the settings in Window->Preferences->Drawing. Turn of Autodetect.