Trouble Signing RBZ


1 Like

Ok, I’ve got a troubleshooting request.

  1. Can you let me know what you used to zip your files before uploading them?
  2. Would you mind testing an alternate zipping application?
    One of our developers was able to unzip your file, then re-zip it using the native Mac app and it seemed to work as expected.

I use the standard Windows10 functionality to make a ZIP file.

Yes, if this makes it possible to sign RBZ files again.

Excellent! I know WinZip, WinRAR, 7-Zip are all pretty popular. Thank you in advance for testing!

Just tested with 7-Zip, unfortunately without success.


I noticed that smaller files work, but no idea exactly what the treshhold is.

We have any further progress on this issue? Its over 2 weeks now and this is getting kinda silly for a “professional” product / company.

Just tested a 12 Kb file that also gave an error.

I use PowerShell Compress-Archive.

powershell Compress-Archive """C:\Users\NeilHome\Source\repos\Building Creator\RBScripts\Building_Creator\Deployment\Staging\*""" -DestinationPath """C:\Users\NeilHome\Source\repos\Building Creator\RBScripts\Building_Creator\Deployment\Staging\Building Creator (unencrypted).zip"""

I tried copying the archive to my mac unzipping, rezipping and it still will not sign.

Nick, onze RBZ doet het wel, maar we hebben heel veel tests gedaan. o.a. alle afbeeldingen eruit gelaten, de file een stuk kleiner maken, maar nooit zo klein als 12 Kb. We hebben onze applicatie opgeknipt in kleinere delen en we hebben nu een structuur die werkt. Alleen rb, html en js files en zo klein mogelijk), maar het is echt zorgwekkend dat een bedrijf als Trimble een dergelijk probleem zo lang laat liggen en zo ontzettend weinig terugkoppeling geeft. Dit loopt al ruim 2 weken en ik heb zo maar het idee dat het nog wel ff duurt, dus het beste kun je zelf van alles proberen tot het werkt

Paul (van Rubysoft / Construsoft)

One engineer suggested that the 7z test failed expectedly bc the rb file and dir are different names (note the "h):
Screen Shot 2022-04-07 at 11.31.10 AM

Sorry, that’s my fault. Had quickly changed the name for the test. I will test it tommorow again.

1 Like

I did several tests this morning with 7-Zip, but so far with no success.

1 Like

So this morning I’m now able to sign my extension if it is zipped using windows explorer. It still fails if I use PowerShell to create the zip.

Note the zip files are a bit different in size.

Also note that I used to be able to upload and sign an rbz that was created with PowerShell.

1 Like

Glad to hear! I’ll leave this to the experts now. I’m sure they will be able to figure out why the PowerShell method seems to be broken currently.

Thanks. In the meantime I rewrote my script to use 7-zip.

1 Like

I tried several ZIP methods, none worked on my file (little less that 7Mb) Only making the file smaller seems to work for me.

Is there any update on this from the SketchUp team? Sorry for being a pain, but there are some important changes to my plugin that I am unable to deploy.

This morning I tried leaving only one single rb file in the plugin folder and still had the same issue.


Hi Sketchup,

Im also sorry for being a pain, but there are not many other options than complain here on the forum, about an issue that breaks the most important process to deploy changes, so here goes…again.
Is there any progress on this issue? Anything at all?

The existence of this issue for weeks on end already, the (none existing) service and the total lack of any feel of urgency is incomprehensible to me as a developer/company/client using the SU Api to develop extensions. Sadly, its not the first time, but this seems to be the avegrage service level when using the Api and running into issues.

At the moment it is still not possible to generate an RBZ file…
Is there any progress on this issue?

We found that some RBZ took longer to unpack and would timeout, so we recently upped the timeout. This went live a few days ago.

Make sure to check the RBZ content after packing, and beware that macOS’s builting Archive utility tend to add an extra folder at the root. Try using something like 7zip to double-check the RBZ. If you have a well-formed RBZ and still have problems, please send the RBZ you are trying to submit to And please include information on how you created the RBZ.