Transparent style views rendering opaque in Layout 2017

Hi,

Any update on this being fixed ?

Did this make it into 2019? Wondering before I update.

1 Like

Hi,
Unless I am missing something, it is not possible in Layout to overlay two or more viewports of the same model and have them blend with transparency. Eg I have one scene showing contours, I have one scene showing roads, and I have one scene showing trees (each filled with a green transparent material).
Each is on a separate layer.
I would like to overlay the transparent trees over the contours and roads, with the roads and contours showing through. It still seems like this is impossible with layout ???
The reason i have three different scenes as I want to apply different lineweights/ styles to each type of information.

Is this possible ???

Yeah, that’s what this thread is about. Up to LayOut 2016 it worked and was beautiful and useful, and they broke it in 2017. They didn’t fix it in 2018, and I don’t see it on the release notes for 2019. I really don’t understand why this isn’t a higher priority than it apparently is.

Hey guys, again I am sorry this fix did not make it into 2019. However, I am hoping what did make it in 2019 will be of some help. We were able to get the Wireframe style to display correctly in LayOut therefore creating some transparency effects is possible.

In my SketchUp file I have a few scenes:
Site Plan (site context contours, sidewalk easement info… etc…) This is Wireframe Style
House (Section of the house)
Trees (plan view of the tree locations)

I bring this into LayOut and stacking the viewports
I create a Trees layer in LayOut then place a white rectangle over top of my SketchUp trees scene. I can control how much i want the trees to be faded back by controlling the opacity of the fill color.
I stack the Site Plan then the house scenes (on a Linework layer)
I vector all viewports except the Trees one which I set to Hybrid.

I know it will not work for all cases but it may work for majority until we can get this working again.

Here is what it looks like.

Trent

1 Like

That’s just bad news, Trent. I don’t understand why this is not a priority.

Your example does look good, though. The trees do look transparent, but unless I’m mistaken, this is only possible with one faded layer, and that layer has to be at the bottom of the stack. IE you can’t put a “transparent” tree over solid grass. Or, in my typical case, a transparent countertop over a solid cabinet and floor. I actually used to do transparent upper cabinets over transparent tops over solid lower cabinets and floor. Now I have to do the uppers and countertops in wireframe. It’s a lot of lines close together on the plan, so I’m experimenting with different colors. I’ll probably try the dashed lines now for one of them, but oh it was so clear and readable when transparency worked! No client or contractor was ever confused about what line was what.

By the way, what was it that got fixed about wireframe display? I guess I never noticed what was wrong.

Hi des… believe me it has been a high priority… we just need to weigh the fix against the risk in other areas and unfortunately one we could not take. I have used your example many times to communicate the importance.

We essentially were hiding lines when we should not have with wireframe. See image below

1 Like

Personally my expectation is that any page layout system professional or not, will have layers and those layers have a working layer blending model, or at least utilise the transparency of the layer content itself. This is core functionality has been ignored for layer content that comes from Sketchup since LO 2016.

It is truly difficult to fathom why this is not a core functional priority for the development team ???

The need to resort to workarounds stifles creativity and flexibility, and leads to the need to utilise other software to achieve very standard image construction techniques.

Can we please have some part of the team look at this and maybe stand by your spiel with the new subscription / release model to add this as an incremental improvement instead of waiting until the next major release !

While I am at it, could we have a per layer blending mode (normal, add, multiply, etc)? I havent fully thought this through but if possible, this would be very useful and would be an alternative way of achieving my needs.

Thanks for all your other great work SU/LO team, I am mostly a big fan of Sketchup / Layout

2 Likes

Hey, Trent. That might be the way to solve this problem. If the root cause here is changes to SketchUp’s rendering engine, and those changes are not easily undone without breaking something else, then how about instead adding a transparency slider to the LayOut viewport objects? This would be the same transparency control that is available for other layout entities, such as the white rectangle you used to fade the trees. If I could do that to a viewport, I’d be golden!

2 Likes

@jwhida and @des to both your points we are aware of the benefit this sort of feature request could provide.

2 Likes

Just downloaded the newest release… and … it seems there is still no progress in this area with the Sketchup 2019.2 release.
Fingers crossed for next time hey
:frowning:

@jwhida and @des … Please try again… I love to be the bearer of good news and in this case it is true.

With existing LO files the viewports will need to be re-rendered to display the updated rendering.
This image is before a re-renderbefore%20re-render
and this one is after displaying the transparent materials.
re-render
Enjoy!

Sorry I had intended on updating this post.
Trent

3 Likes

OMG is this true? theres my number 1 reason to migrate to 19.2. good job

2 Likes

Just downloaded and yes, layer transparency does appear to be fixed.Chill the champagne!

Thanks, Sketchup team!

2 Likes

Its 2020 now and I’m still using 2019. Ive got a similar problem but not quite the same. I’m able to render stacked viewports on screen but when I try to print the top layer fills in with white thus having everything underneath it disappear. This seems to happen ONLY when I print - as in, I don’t even see the error in my pdf viewer after its been exported (I use preview).

Hi all,

I’m on v20.1.228 on a MacOS Mojave - and Layout 2020 appears to have this issue still - my example: glass guardrail with 0% opacity full transparent in SU:

But this is how it appears in LO:

As you can see, the shadows (and cladding material of the wall) appear to peek through but the other lines of the sliding door panels behind do not show…

Please tell me this is just a setting that I have to toggle on/off as this is very disappointing if it’s this bug all over again…

Thanks in advance for any response.
Janvin

I tested the earlier example file in 2017, 2019.3, and 2020.1. I could see that the topic problem was fixed by 2019.3 (meaning too that the 2019.2 fix still works). What you are seeing may be something different. Are you able to get a very cut down example file we can check?

Archive.zip (6.4 MB)

Hi Colin, SU and LO files attached - I found this discussion that relates more to my issue than this thread does perhaps

and my LO file appears to concur what’s happening in this thread I found. So I’m not sure if my discussion needs to be tossed over there for more relevant tracking. And as it appears in that thread, this issue hasn’t been resolved. Would you know if it’s on the radar to be resolved by the SU/LO team?

Thanks!
Janvin

Not related to your main question, but you have Profiles turned on. You could turn those off while working in SketchUp, things will speed up a lot. Then turn Profiles back on before updating the LayOut reference.

I am fairly sure that what you are seeing is not a problem, but is just how things work. To get transparency you need to render in Raster, if you use Vector, faces will be filled in. For the model that looks wrong, you’re using Hybrid, and the Vector part of that is causing the faces to be opaque. The model that looks right is set to Raster.

You could go into your model and delete the face, rather than rely on filling it with a transparent material. Then Vector or Hybrid will look correct. Finding your way to the face is a small challenge, given that it’s see-through. You could set Face Style to Monochrome, to speed up finding the right face.

Hi Colin,

thanks for the suggestions re unrelated - yes, I typically have a “Design” scene that has its style set to minimal graphic-intense settings (ie. no profiles, no shadows etc) - I just deleted about 20 scenes before sending it your way.

Aww - it sucks that I can’t have a Hybrid viewport that respects the transparency right down to the vector line behind it - as mentioned, the other thread that I found, it seems to be an issue others (perhaps not enough) are finding to be an annoyance as well.

As for the transparency for the guardrail - I only had it set to 0% just as an extreme to show there’s no threshold as to when the vector lines may show up - e.g. related but unrelated, I recently found out that the threshold for transparent material to cast shadows is 71% opacity - ≥ 71% opacity, a material will cast shadows while an opacity setting less than that will not cast shadows - not sure if that was ‘intentional’ or just the way things worked out.

Back to this topic, I just hope this will be something that is just by default in future releases as opposed to just a convenient way (easy-out) the SU / LO developers decided to have it displayed in the viewports. My situation is a rather simple example of this - the other thread has others with projects that would required intensive workarounds, especially when revisions are required.

Thanks for looking into this Colin.
Janvin