Transferred Model from one computer to another, all lines are jagged?

I transferred my sketchup model from my laptop to my pc. Running the latest versions of SketchUP on both. The model looks great on my laptop but appears very jagged on my PC. I’ve tried changed the anti-aliasing settings but it doesn’t help.

So you have the 1070 on the laptop?
What is the screen resolution and display scaling set to?

What graphic card on the desktop?
What monitor? Display settings etc.

I agree with @MikeWayzovski that this sounds a lot like a difference in screen resolution between the two computers.

The laptop and PC are both set to display 1920x1080. Scale is set to 100% on both computers. NVIDIA GeForce GTX 1070 on the PC. Intel HD Graphics 520 on the laptop