ThomThom SubD plugin causes Vray Asset Editor Menu to be unstable (freezing)

Hi! I’m sorry that writing here about SubD plugin but I almost always can’t get access to the http://evilsoftwareempire.com/ site, don’t know why, maybe this is somehow connected with my placement (Russia, Moscow). Even when I bought a SubD and Vertex tools for a whole day I couldn’t able to activate my licenses. Sending a message to ThomThom didn’t do any success because my message was ignored even for now but hopefully somehow after hundreds of try it was finally activated that means that sometimes it could be connected to the server.

Sorry if you’re @ThomThom not controlling customer support and it must do someone other I don’t know it but you should agree that this is not ok when a customer can’t get help in time paying money. So that was an explanation why I’m writing here. Now, what about SubD’s issue I’ve got while working with Vray. I’ve noticed it in a Vray’s previous version and in actual too (V-Ray for SketchUp 4.20.01). Try to take a look to my .skp doc. Here is a mesh of a mousepad created with the help of SubD and ClothWorks plugin. The problem is when I open a component with a mesh and add some vray materials and then try to switch between materials (select one of them while the component still opened) Vray Asset Editor becomes unstable, it is very freezing that you even can’t move the window. If I’m doing the same while the component not opened everything works fine. I’ve got a teamviewer connection with ChaosGroup support just right now and they could reproduce the issue, after some manipulations it becomes clear that probably SubD plugin causes the problem because when they fully deleted it from my SU the workflow became normal. So could you check it, please? Thanks!

chaosTest.zip (7.0 МБ)

There appear to be a number of Russian ISPs that block a large range of IP addresses related to hosting services like Digital Ocean, AWS etc. These users have had to use VPN to bypass that. I’ve not found a good solution to this because I have no idea what are “safe” IP ranges to use - and I don’t really have much option to pick an IP when setting up servers on these services.

If you sent a message to anything other than the official support form on the website (https://evilsoftwareempire.com/subd/help) then it’s likely to get lost. I understand that’s a challenge if you struggle to access the site due to IPS blocks. However, I very rarely check my SketchUcation message. I would recommend you try to use a VPN or contact your ISP to unblock the UP for the domain name.

Hmm… that’s strange. I will try to reproduce.

A subdivided mesh? Or just any group or component?

I probably haven’t met the same problem with other meshes seems like it only appears with subdived but I’m not sure. I also tried to convert a subD mesh (here is an option in your plugin you know) to a standard mesh and no success too - vray asset editor still freezing. But after I simply deleted sudD plugin the problem becomes solved. You can watch my screen record showing the problem by the link https://dropmefiles.com/5Pydc

I understand but I was trying to go to the site with my mobile operator’s internet (with iphone), then from my 2 other machines that use different providers. After that I ask my friend to try to go to your site and he can’t get it too while he is far-far away from Moscow (1000km) and he, of course, use different internet provider. Maybe it cost to try to solve somehow a problem with access. What if there are thousands of Russians who’d like to buy your product but they can’t do it. :grinning:

I just updated VfSU to the 18th Feb update (Update 2) and I opened the component in your file and I do see the VfSU dialog becoming sluggish and unresponsive when I tried to add a new material from their dialog. (SU2019.3)

And I also observe that it’s working fine when SUbD is not enabled. So clearly there is a clash between the two extensions. I need to look closer at what’s going on here. I might have to contact ChaosGroup to get some insight to VfSU is doing and compare that to what SUbD is doing.

By the way I just tried to explode the component and after it even can’t open Vray Asset Editor it is freezing and you can’t do any actions at all. Only closing the Vray NeUI process in a Windows task manager helps SU to continue to work in a document while trying to open Vray again will not make a success - it needs SU to be restarted.

It appear to be a general issue with many (if not most) Russian ISPs…

I did some research and found a number of articles on this topic, and there wasn’t any easy solution. It’s impossible to for a website owner to have a list of all Russian ISPs and work with them. Some people have tried, but yielded no result. Technically this is very difficult to handle since there is no insight to what IPs are getting blocked - because the list of IPs changes every so often. And for me it’s especially challenging since I’m a one-man band which do this beside my normal full-time job.

Again I’d recommend trying to use a VPN as a workaround. This has worked well for other Russian users.

You can also Disable it from Extension Manager - that will have the safe effect (after restarting SketchUp.)

Yes, thanks. Hope it will be fixed soon)

1 Like

Of course you better know what to do. But I have never get some problems with an access to legal sites. You don’t even have to go so far, for example https://artisan4sketchup.com/ works fine.)

Yes, this solution works on 1 of my machines. And I’ll check it on another soon. Because yesterday when I was trying to found out what causes the problem by myself firstly I simply decided to disable all the plugins I’ve got. But the problem was not vanished after that, and today ChaosGroup support adviced me to fully delete it from the system and the problem was vanished. But probably I’ve missed yesterday subD plugin when was switching off my plugins.

I could try to change host - but there would be no guaranty that I’d later be affected by the IP bans. I cannot afford to spend time and money to move the site around every time it get affected.

Here’s one article that breaks down the issue:

They conclude at the end:

The conclusions we came to after the block

There is one and it’s rather disappointing: it makes no sense for us to focus on the Russian market anymore. At some point a group of people, who are not fully aware of their actions, might just nip your business in the bud or at least seriously damage it and we are not ready to work under such conditions. We will always provide our services to Russian customers, but after what happened we’ll give preference to some other markets.

Basically, battling systematic IP ban by the Russian government is not easy. :confused:

1 Like

It’s a pity of course I see( Thanks for a detailed reply.

evil empire vs bigger evil empire…

3 Likes

It is probably the name of ThomThom’s domain. Government people anywhere have no sense of humor and I would guess that the Russian government people have even less.

No, they aren’t targeting my site directly. But many companies/services use Amazon AWS, Digital Ocean etc - major hosting services. Some of these services aren’t approved by the Russian government so they impose ISPs to make large-sweeping ban’s on related IP addresses. As part of that a large number of unrelated services gets affected because the ban is over-zealous. But you have no way to submit an appeal etc. Larger companies have resources/time to handle this, setting up proxy servers ets. I don’t. :frowning:

2 Likes

I had a quick digging around. I think I know where it happens. But I still don’t understand why it happens with VfSU and open component. Need to further understand what VfSU is doing.

I believe you can do it :sunglasses:

1 Like

I think I have a way to avoid this. But I’m going to need a few days to complete and verify it. I’ll post back with update.

From what I can tell, it happens when there is a large amount of entities in the current context (open group or component).

great, happy to hear it! waiting for an update. thanks!)

I just deployed version 2.1.5 which I think will address your problem with SUbD and VfSU. At least it did so on my machine. I’m still not clear on why it cause an issue, but that’s something I can figure out with ChaosGroup. Meanwhile I hope to have unblocked your workflow.