Things shrink when I want them to go

Sorry in advance for the title and certainly description, as I am not sure how I am going to describe this… The question has been going around in my head for days (and before that) and I just need to get words on paper, so please bear with me.

I need to make a little “thing” which will be 3D printed… This:

I need to fit a small ball will fit into the hexagonal section so that its held, but not tight… So like many projects I just increase the hole minutely and re-print until it does what I want.


But I have run into something before that I can’t explain but this time it has now stopped me in my tracks and is causing me a nightmare… let me try and explain.

So I start out with a hole/hex which is too small whihc as you can see from the first picture has a radius of 7mm… And I want to enlarge it by 0.1mm… So I use the move tool and find the “magic” point (blue dotted line) Which allows me to change the size… I grab it… move it outwards with the mouse… And then type 0.1 at the bottom… Like this.

But when I hit return (after entering 0.1) I would expect the radius to be 7.1mm, but its not… The hole got smaller and by much more than 0.1mm.

So I let me try again… This time 0.2mm… This time I found the magic point… Pulled it out so I knew I was going in the right direction… And then typed 0.2mm.

So now I would expect the hole to be 0.2mm bigger… But again its smaller.

5

So this only happens with minute size adjustments… So just to prove my technique is sound (and I have done this literally 1000s of times on other models)… This time 1mm

And now the hole has grown… By 1mm:

7

So there is clearly something I am doing wrong with small changes… When even I try to make the hole bigger, it gets smaller by a random amount… I have tried rescaling everything x100 and then making adjustmetns in mms, but I get the same issue…

I have also played with the “precision” settings… But its the same.

I realise there are other ways to achieve what I am doing… But I would like to understand that this little technique stuggles when making tiny adjustments.

Does this make sense? ANyone have any ideas?

Jon

Upload the file. See if it happens for others.

OK… But to be honest, for the purpose of those picutres, I simply drew a 10mm circle and pulled it up to 10mm… And then draw a 7mm hex and pulled it down to a hole…

So here is one I just knocked up which shows the issue…

Edit: The file I uploaded didn’t have a way to download… So I have zipped it.

test.zip (461.7 KB)

I didn’t have any difficulty with your model but I redrew it with your 14mm radius on the hexagon and I dragged out the hexagon on axis so the cardinal point or magic point, as you call it, is on axis. You can see that reducing the radius of the hexagon by .1 does what it is expected to do.

Another thing I noticed in addition to the random way you drew the hexagon is that you have Length Snapping enabled. This can create problems. Turn it off.

Hi Dave… You know I am trying to make the hole BIGGER not smaller? I had no problems making the hole smaller… But when I make it bigger (by adding a +ve value) the hole would still shrink.

From your video I notice you are clicking on a corner… I wasn’t aware you could do that… And its helped a bit… But I am still finding that sometimes I put in a +ve value and the hole gets smaller… The problem I have that the example I gave was just to show the issue… I am actually changing the size by 0.01mm so its almost impossible to see… But using the Dimensions tool is a great tip and will be helpful.

If I do this using the “cardinal point” and make the hole a tiny bit bigger, it still shrinks instead and I can reproduce that at will… I am using SU18 by the way, so I wonder if things have chagned in 19 or 20?

Can I ask 2 questions

  1. How do you bring out he Measurements into a floating tool… That could be helpful
  2. What do you mean by length snapping? How did you know it was enabled from my pics? And how do I turn it off?

I was clicking on a cardinal point. It happened to be on the corner.

It would help to increase the Precision, too.

This has not changed since at least SketchUp 3.1. (I just tested in 3.1 and it works the same way.

It’s can be brought out as a toolbar. The only reason I dod that is for these GIFs. I wouldn’t ever want it floating like that in practice because it would be forever in my way.

Length Snapping is a setting in Model Info>Units. I knew you have it enabled because I looked at your .SKP file. I turned it off by unticking the box for it.

The smart thing to do would be to start a new file, edit the Units settings to suit the kind of modeling you do and then immediately save that as your default template so you have a good starting point. While you’re at it you can edit the style if you wish and zoom in or out. Also purge the 3D Printer Build Volume component from the template since you don’t need it.

So I have been playing and I am still a little confused.

If my hex has a radius of 10mm… And I grab a corner and shrink it by a radius of 0.01… it should go to 9.98… But it doesn’t… And I am still getting it doing the opposite to what I want.

Let me try something… I will start at 10mm and reduce by 0.01mm each time…

And I get

10.000 -> 9.982 -> 9.998 (why did it go back up so Undo that one) -> 9.977 -> 9.968 -> 9.49

Surely it should have gone

10.000 -> 9.980 -> 9.960 -> 9.940 -> 9.920 etc.

The odd thing is, that if I do it again I get different values again… This time:

10.000 -> 9.987 -> 9.977 -> 9.961 -> 9.955

Am I expecting too much precisions? I don’t think this is the case as if I scale this up to 100x and then reduce by 1mm, I get the same problem…

I have already played with the precision option and it didn’t make much difference… I am obvious never going to need this level of precision… But I am now trying to understand what I am looking at and why 0.01mm does not equal 0.01 in this context?

Really sorry to keep on here… Just trying to learn/understand

Jon

what do you have the units precision set to?2020-05-26_16-27-55 ?
If set to three places the result will be what you are expecting when using the offset tool.

Did you turn off Length Snapping like I suggested?

Yes… Length snapping is off… And it always was to be honest as in my “real” model its based on my 3d printing template where I have snapping disabled… But for the purposes of my example, I just created a quick and dirty model…

So I am still not understanding the precision settings… I have now set my precision to 0.00mm…

And now if I reduce the hole by 0.01 each time it goes:

10.00 -> 9.98 -> 9.96 (looking good) -> 9.95m -> 9.95 -> 9.93

But if I change precision to the highest (0.000000).

Now when I do the same thing and reduce the radius by 0.01, the diameter goes from 10.000000 -> 9.982843.

Whats even more strange is that if I repeat this… By doing UNDO and then reducing again by 0.01, each time the diameter ends up different. So doing this 5 times gives

9.982843
9.991001
9.990024
9.984884
9.993869

I dont’ get what is happening here… And as another test, if I scale this up x100 and then reduce the hole by 1mm, I get

998.033916
998.094079
998.000000 (Hang on… What did I do differently here as this is PERFECT).
998.228031
998.044202

I can’t understand why I am not getting the same results each time. Is this just a limitation of Sketchup because I am working with such small numbers?

I’m not seeing the same issue and never have in any version of Sketchup so I have to think it has something to do with the way you are doing it and not a limitation with SketchUp.

1 Like

How exactly are you doing the reszie with the Hex? If I draw a 2d hex and try and move it, the whole thing moves… What do I need to do it resize it like you are.

I did another test of my Hex in a cylinder and this time I kept the precision 0.000000, but resizes large/normal amounts (1mm)… And I still get the issue…

When I start with a hole at 10mm and then reduce by 1mm, it goes down to 8.047949… And if I repeat I get a different number each time.

I have done this for years with no issue, so I went back to something I know… A circular hole (i.e a washer) and its fine. If I start with a hole of 10.0000000 and reduce it by 0.001mm, the result is 9.998mm as you would expect.

So this has somethign to do with non-circular holes and I wish I knew what I was doing wrong.

Edit: With the 2D hex… I worked it out… Only some corners allow a resize… Others move the object… So now with a FLAT hex, I do not have a problem… If I start with a 10mm hex and reduce it by 0.01, it does what I ask and reduces to 19.980000.

hex

@jweaver, most likely your new polygon is drawn on axis.

Always try to draw polygons, circles (and arcs) on axis. (as @DaveR already mentioned)

If for some reason you can’t change the radius a small amount by dragging a cardinal point > input a new value, you can try doing so via ‘Entity Info’. In that case you will have little succes with small changes like 0.000001mm. Make a significant change first and only then to the desired radius.
See image above,

And this is probably why dragging ( >release at some “significant” distance) works with small changes. For in between you release the cardinal point at a “significant” distance from its original position. And only then enter a new increment or decrease in radius.

@g.h.hubers… You have nailed it… But not quite for the reason you described… But the penny dropped when you said what you said…

I have drawn everything “on axis” (thats a habbit I got into years ago)… But I just realised what is happening…

If I do my resize using a corner which is “on axis” its perfect

But if I take one of the other 4 corners (whihc in the case of a Hex is off axis)… I get the problem

So a question… How do I know which of the 6 corners of my hex are “on axis”… Is this a case of just keeping an eye on them… Or is there something I am overlooking?

I am still seeing my random (getting smaller when I want it bigger) problem and havn’t quite worked out what I am doing to make this happen…

So can i go back to that question… Say I have the object in the picture above and I want to make the hole slightly bigger, what is the correct way to do it… The way I do it is

  1. Grab the cardinal point, edge or what ever
  2. Move it dramatically in the direction I want to go
  3. Type the value in the Distance box.

Is this the correct way, or should I be doing it differently…

Got ot say at this point a big thanks toi yourself and Dave for helping here… Once I get a doubt in my mind I can’t let it drop until I understand.

Jon

There are only four cardinal points. The two points on axis and the midpoints of the sides. The other four corners are not usable for resizing as cardinal points. You can tell when you have a cardinal point if you hover over the edge of the polygon or circle because the edge won’t highlight.

That isn’t evident in your example model. The hex was dragged out at some random angle.

Keep an eye on the model axes or the component/group axes when editing.

1 Like

I’ll try to answer in several separate posts:

Your (first?) uploade zip file is what I looked at. I dumpt the model into My modeling space (still with its system axes, nothing rotated) and your polygons were not on axis. Hence my saying so.

1 Like

As @DaveR points out, your hexagon has two corners and two midpoints as cardinal points.
All depends on what is closest to the axes.
If you slightly rotate a hexagon that was on axes, say 22.5 degrees, the cardinal points will be the same.
If you rotate it slightly more, say another 22.5 degrees, you’ll get a different set of cardinal points. Again the ones closest to the axes.

Circles and polygons are no different in how/where cardinal points are.

They don’t always have four (4 is maximum) cardinal points. And there are some rules.

  • If the number of segments is divisible by 4 > 4 endpoints as cardinal points, closest to axes.
  • if the number of segments is not divisible by 4 but still even > 2 endpoints and 2 midpoints as cardinal points, closest to axes.
  • if the number of segments is uneven, > 1 endpoint and 1 midpoint as cardinal points, closest to axes.
2 Likes

Hi all… Sorry for the late reply, had some problems with work. Thanks for your help with this… What you say makes sense and there is still something about Cardinal points I want to ask but thats for another day…

I am printing the object, doing a test fit and then tweeking it by TINY amounts just to a perfect fit and am still struggling…

Here is the object in question…

insert 8 - Fraction Tighter.zip (4.4 KB)

I have used this same design with a circle and have had zero problems in the past… But having a polygon (which is effectly a circle with less sides) is causing issue and I don’t fully understand whay… But I am getting there.

Before I let this drop, can I just check that my work flow is correct.

The way that I am making the hole bigger/smaller is to

Use the MOVE tool, click on a corner… move the corner dramatically in the direction I want… Type a number (in this case 0.01) and hit return… .

Is this the correct way, or are there better/different ways to achieve the same?

Thanks in advance for any help with this last point.

Jon

Yes, that’s correct, a significant move and only then type the small displacement of that particular cardinal point.
( When trying through ‘Entity Info’ it requires two steps of changing a radius. I mean with changed as small as 0.000001mm).

Best way to check these things yourself is to place a dimension and change settings to highest precision. You’ll instantly see the chance (even up / down to 0.000001mm) without waiting for our answer, :wink:.