There's nothing appearing in my extension manager

@IanT
What version of Internet Explorer do you have ?
Could you also post your ‘Security’ settings for the html file I outlined a few posts back…

@TIG, what would the test code be for opening that html file in another HtmlDialog from Ruby Console…

john

Capture%202

i got de same

phenix.bmx
You can copy and paste this ruby code into the Ruby Console and it should open the Extensions Manager.

Open the Ruby Console in Sketchup by clicking Windows > Ruby console. Then paste the text into the input box at the bottom of the ruby console. Then type the return key.


dialog = UI::HtmlDialog.new(
{
   :dialog_title => "Dialog Example",
   :width => 800,
   :height => 600,
})
dialog.set_file("C:/Program Files/SketchUp/SketchUp 2019/Dialogs/ExtensionManager/extension_manager.html")

dialog.show




Thanks @sWilliams

@phenix.bmx
Please copy/paste+enter the whole code as provided by @sWilliams above - into your Ruby Console - and see what happens…

After i clic on enter i see the box "Extension manager " as is supose to look like, with de red button in de botom. So y quit ruby console to go se if it was ok in de window option but it’s sill de same empty white page.

see if turning on ‘Show file extension names’ [or whatever it’s call on windows] and try again…

john

Try this Web [v. HTML] code… it also works for me…

dialog = UI::WebDialog.new(
  {
    :dialog_title => "Dialog Example",
    :width => 800,
    :height => 600,
  })
dialog.set_file("C:/Program Files/SketchUp/SketchUp 2019/Dialogs/ExtensionManager/extension_manager.html")
dialog.show

in the ruby code?

Yes, exactly as you did with the other code example…

Have you considered trying the French version of Sketchup Pro 2019.
available at: https://www.sketchup.com/download/all

Best
Skip W

Will I have to pay again?

I got de same problem even in french . I really need to resolve that how can sketchup can help me?

It seems unlikely, but have you tried turning off your antivirus software.

OR… checking that your antivirus software is NOT “blacklisting” SketchUp and preventing it executing certain things.
Clearly SketchUp’s Ruby-side can open the dialog properly, but SketchUp itself cannot !

Can any one from the SketchUp team participate - please !
We are running out of ideas…

1 Like

Please go to the following directory, find the file named debug.log and post it in this forum thread.

C:\Users\user_name\AppData\Roaming\SketchUp\SketchUp 2019\WebCache

The attach button is the up-arrow. The seventh button from the left.

1 Like