The is getting frustrating


#1

SU PRO 8
MOVE TOOL RANDOMLY STOPS WORKING
UNDO TOOL RANDOMLY RUNS OUT OF UNDOS
PUSH/PULL TOOL RANDOMLY STOPS WORKING
CRASHES ON CRASHES.

working with a pretty small file. textures off,
MacPro quadcore, 32 gig RAM

Giving Rhino serious consideration.


#2

It’s Mac and Mojave. Not Sketchup.


#3

How long have you been using SketchUp 8 Pro? When did this behavior start?


#4

Definitely not Mojave. He’s running a 2010 edition of SketchUp on Mac OS 10.11, which is over three years old.


#5

Rhino 6 is the latest version, but windows only.
Version 5 is still downloadable for Mac.
You will probably need version 3, but You can only download it with a license key.


#6

I’m running 10.11.6 and the latest version of Sketchup

It’s been going on since I upgraded to Sketchup Pro 2018

Best

BR


#7

Based on what you write, I wonder if there is a compatibility issue between OS X 10.11.6 El Capitan and SketchUp 2018 on your hardware. Is there a strong reason why you need to stay with El Capitan? I’d note also that an AMD FirePro isn’t the best graphics adapter for SketchUp.


#8

In your first post wrote:

Not SU2018 so there was confusion. Please complete your profile with the SketchUp version.

I run SU2018 on my MacBook Pro with El Cap but I have an Nvidia GPU. I don’t have any of these issues you describe. I’d side with Steve and guess it’s your AMD FirePro. Perhaps you can share a SketchUp file where you see these sorts of issues.


#9

I ran out of undo’s in this model pretty quickly. i can go back a couple of steps then the magnifying glass appears.
I just updated my SU 2018 today.


#10

How are you activating Undo?

It sounds to me as if you are using the keyboard shortcut. On the Mac, Command-Z is Undo. Z is Zoom for which the magnifying glass is the cursor. It sounds like you’re either letting go of Command or it’s not continuing to be active.

Do you get the same behavior–running out of undo steps–if you repeatedly click on the Undo button on the toolbar?

And what exactly are you attempting to do in this particular model?


#11

CMD-Z to activate undo. i’ve also disabled the Z shortcut to see if it was a keyboard error (it’s not)

I was trying to undo the follow me tool


#12

Are you sure the keyboard shortcut for Zoom hasn’t been reset? The only reason for the magnifying glass icon to appear is if the Zoom tool is being called.

Try using the toolbar Undo button instead.
2018-12-19_14-33-59


#13

the keyboard shortcut has been reset. but this is irrelevant to the problem. It happens whether I disable the Zoom shortcut or not. even using the toolbar undo, I get to the same problem. No more undo’s.
If I go to Edit / Undo I see the Undo grayed out and underneath it I see Redo Observer event Change


#14

this is one of your extensions using up undo’s…

which do you have installed…

john


#15

a lot. I start disabling them in groups and see which one it is


#16

suspect renderers and report writers first…

EDIT: what is DL face_data, attached to evert face in your model?

john


#17

Obviously only relevant if you have issues with other apps too.

What type of mouse are you using and what connection - wired, Wi-Fi or Bluetooth?

Have you ruled out mouse batteries as an issue?

There is a little known mouse issue I had previously, where the laser light (of the mouse) is interfered with by other lights nearby at exactly the same horizontal level as the desk - ex. an LED light from other hardware close by.


#18

i don’t know what DL face_data is?


#19

From a little searching around, maybe you have some kind of daylight calculating extension from “De Luminae” installed?
https://deluminaelab.com/dl-light-manual/English/howto_prepare_model.html


#20

hot ■■■■ I do! lemme deactivate and let you know. Thanks for the tip Ian.