The Dreaded - Unexpected file format

To all,

I use SketchUP Pro 2014 for my self employed business, so you can imagine my horror when after working on a file for about a solid week or more it popped up a message this morning saying:-


There is no where to go after this message, even the .skb file after re-naming says the same thing. O.k. there may be a million reasons for this, but I think I’ve resided to the fact that I’ve just lost many many hours work & will have to start up again at last Win Pc restore point of last Friday, heck I even worked on this file over the weekend… :frowning:

Therefore I was wondering if anyone has experienced this before & have had any success in sending their file to SU HQ the official way for file fixing.

Over & out,

Hi Clayton

There could be many reason for that error message. But one of the causes I found recently to be due to a bug in the Ruby API where an extension could potentially cause that if it sets an attribute with an empty string (or something that evaluates to an empty string.)

Do you use extensions in your workflow?

I’m not sure if it can be restored. It would depend on the cause of it. But I can forward it internally.

Btw, are you able to open the backup file? The .skb file that should be in the same directory?

Yes, same result with backup file as noted & yes like most I use quite a few extensions.

I sent the file to SU HQ, if you could fast track this however, that would be a god send.

Where do I e-mail it though…?

Over & out,

Ps. I’ve only used of late the extensions that SU say’s are compatible from the extension warehouse. However I did load one not on the official list called 2D Tools ver.5.6. This I used on this file yesterday & was one of the last things I did. I have been using this extension for about a week though prior to this, so might not be that extension at all…!!!

This bug in the Ruby API was discovered recently a few days ago. However, there need to be a bug in the extension as well that sets an attributes that would corrupt the model.
Having said that, it might not be an extension being the cause of this. It’s a generic load failure message.

If it’s already sent to Support then that’s ok. No need to send again.

O.k. Thanks for the offer anyway, this forum I’m new to & have only just seen the upload icon. So will try & upload it anyway, as when I sent the file this morning, a pop up page confirmed the message had been received, but nothing about the attachment or indeed an confirmation e-mail after.

This would be a comfort to SU Pro users I’m sure.

Anyway all I can do is play catch up on the lost work, some long day’s ahead, as I doubt this will get sorted anytime soon if at all, being such a popular programme my e-mail must be on a mile long to do list I guess at SU HQ.

In future I’ll make regular ‘save a copy as’ as just saving backups just overwrites all your hard work with a recent possible corrupt file your not aware of, like in my position. Save a copy as does the auto rename to prevent write overs.

I make regular components & do a save as to file for most building elements for use in other models, so will be doing this more so even with one off created items, as this will help me catch up faster.

O.k. forget the upload, I’ve just tried & it say’s 3MB is the largest upload size, my file is 5MB.

Over & out,

Yea, I completely feel your pain. I used worked 7 years at an architectural office and I had my share of data loss due to application errors. Never a fun experience - especially when the backup mechanisms also fail. I hope support can find a some solution as part of their investigation.

From my own experience I would recommend an external harddrive where at least daily backups are done to. Often they will come with software that sets up such backup schedule and you might even be able to use Windows’ own backup system. Such a setup has saved my time and time again.

Do you have Dropbox or Google Drive? If so you can upload to a service like that and post a share-link on the forum.
Zipping the file might also make it small enough.

Yes, have an external portable hard drive, this gets backed up after any work. But it’s set to back up any files that have been opened/edited with same file name, so overwrites happen, corrupt or not. I’ll have to sort out a way to make these backup not overwrite old files, the hard drive will rocket in size, but will be worth it for sure.

My Win 7 Pro O.S. managed to root out a ‘Restore Previous file version’ I’m currently working on again from last Friday, not too sure, I may have renamed that file at that point, better than a complete re-draw.

Yes, have a Drop Box a/c, will try that, thanks for the advice.

Over & out,

To all,

I think this shared link will take you to my Dropbox account to interrogate this locked out file. Thanks to all again.

Over & out,

Ext06-2014-SU Model-01

Hi Clayton,
I was able to recover your model. I’ll send you a PM with a download link. Thom’s intuition was right, this was caused by a bug we recently patched for the next version of SketchUp. It was an extension that caused the model corruption due to this bug. Just in case you want to disable the extension, I’ll say that it appears to be Layers Panel. But again, it was not the developer’s fault. We’ll work with him to get the extension patched.


Hi Bugra,

Thanks for the quick turn around on this, it’s most appreciated indeed. I’ll look out for the separate e-mail with link.

However, I’m now a little concerned on what to do for the best on on-going work & other projects, i.e. use the dumb SU layers panel or take a risk using the Layers Extension with layer management controls you’d expect as standard. It’s been fine for weeks, so am a little suspicious if sole cause. The last project I did from start to finish, about a solid weeks work had no glitches.

That aside, I hope SketchUP HQ will seriously look into the Layer Panel & provide proper layer management controls in a future upgrade.

Thanks once again for all your help.

Over & out,

I’ll reach out to the developer of Layers Panel and notify him about the bug. Keep an eye out for an update of the extension. Until then I’d disable it to be sure you don’t get more trouble.

Clayton, I sent it as a private message in this forum. You should see it under Messages on your profile page.

Hi Bugra,

Still getting use to where all things reside on this forum, but I did get the recovered file o.k. straight after my e-mail to you.

Have been working on the recovered file since this morning & confirm all is o.k; thanks again for all your help, has saved me a lot of potential grief from the client…you have saved the day. :slight_smile:

All the best,


Hi guys,
I finally have got back from a trip, and have time to look at this.

Could you give me some infos on what you found? What makes you think this was caused by Layers Panel?
Did you find an attribute which name indicates it’s from LP, with an empty key? In that case, what was the attribute’s name, and more importantly, what was the value?

@bugra @tt_su

1 Like

Hi @jiminybillybob,
Yes, a Page had a dictionary attached to it with a name jbb_layerpanel something. I don’t remember the exact name. Does that sound about right? This dictionary had an empty key in it.
Thanks for looking into it.

We’ll keep eye out in the EW moderation and fast track this one.

If you have time, could you look it up? Having the name and value would be really helpfull to understand why LP created an empty key in the first place.

In the meantime, I modified it to validate every key, and will update soon.

nil values would also evaluate to an empty string. So if the key was computed somehow you might have ended up with nil as a result of a failed function.

I published a fixed version, you guys just need to validate it :wink: