Textures suddenly destroyed and geometry becomes x-ray mode

I was making a tiled wall that has a concrete texture projected on the face of the tile from an exploded photograph. Sketchup crashed. When I reopened the file, the tiles lost the texture and are now this jaggedy white/blue that flickers when I orbit around the object. Also, the geometry appears to be somewhat x-ray, in that I can see all the edges all the way through. I have tried restarting several times. I am up to date on the latest version of sketchup and Mac OS. Has anyone seen this before? Can you help? Thank you.

Screen Shot 2020-08-06 at 6.44.24 PM|241x500

Could you share the .skp file?

No, I’m sorry. It’s for a client and there are confidentiality issues.

Well, it’s pretty hard to tell what’s going on with no more information than we have. That screen shot doesn’t tell us much of anything except maybe there’s some Z-fighting but that’s just a WAG.

I understand. I was hoping to reach someone that has encountered this problem before, and what they did to resolve it if they could.

Long way from origin?

1 Like

No, it’s just a few feet away from the origin.

I thought maybe the texture image was too high res and that was making my graphics card freak out, but the blue/white pixilation happens regardless. Even if I try to paint it a solid color. I ended up deleting the tile wall from the model entirely. Then I rebuilt the model in a new file and copied and pasted it into the master model. That seemed to do the trick for now. Thank you everyone who tried to help. I do appreciate it. If anyone else runs into this issue and knows a fix, please let me know.

It’s z fighting.

How do I fix z fighting?

The same symptom showed up for me recently, and the object was near the origin, but something else in the model was a long way from the origin.

What happens to your scene when you zoom extents? If it suddenly becomes very small, that would also point to something being a long way from the origin.

Colin - Yes! When I use Zoom Extents, it zooms way, way out! I have checked for hidden geometry somewhere way far away from the origin, but have not been able to find anything. Sounds like we are having similar issues.

There are different ways to fix the problem. One way that works most times is to do a left to right selection around the origin area, big enough to include all of what you want to keep, then type command-shift-i (or Edit, Invert Selection), then delete, and zoom extents again to see if it looks normal now.

I will try that. Thank you Colin!