Texture import/edit hanging SketchUp

Are you referring to 2019.3? When you installed it, did you right click on the downloaded installer file and choose Run as administrator?

Hi Dave. I downloaded it and installed as it said. I was logged in as admin. Yes 2019 3

What does this mean? As what said?

That is not the same as using Run as administrator after right clicking on the installer. To make sure it is installed correctly, quit out of SketchUp and LayOut if they are open. Find the installer, right click on it and choose Run as administrator. A window with some different options will appear. Select Repair and let it run.

OK thanks I’ll give it a try :+1:

Another question or four. What is the image you are trying to import? How large is the file? What method are you using to import it? How are you trying to edit the image?

At what point does it ‘hang’, could it be that the import dialog is opening off screen?

1 Like

As soon as I click on the create material button it hangs. I have screen running and any dialog box opens on the middle screen, nothing appears but I get a beep when i click anywhere in the sketchup window. I have run repair as Administrator and still get the same issue ?

It sounds like the Create Material dialog is opening off screen. If you hit Escape does that free up SketchUp? Have you tried going to Window>Preferences>Workspace>Reset Workspace?

Also try: Hit Alt+Space, then hit m, then tap any arrow key and finally move the mouse around without clicking until the Create Material dialog comes into view.

I have tried all the above, closed down to just the main screen, still nothing appears ? reset the workspace nothing ?

maybe uninstall and start again ?

I have now uninstalled and re installed !!! still no dialog

Probably no need to uninstall.

You might try going to User/App Data/Local/SketchUp/SketchUp 2019/SketchUp and editing the file called PrivatePreferences.json. Can you see ModalEditMaterialDlg?

The User/Appdata directory is normally hidden so you need to make it visible. Just searching for it in the Windows Explorer panel under your username should make it show.

What do i edit ?

“ModalEditMaterialDlg”: {
“x”: -5262,
“y”: 1307

-5262 is a red flag.

Try changing it to something like

“x”: 1349,
“y”: 336

That’s what mine shows. Edit it and save the changes and then open SketchUp again.

Perfect thanks Dave

Glad that helped. Out of curiosity, where does that dialog appear on your screen now?

In the middle of the sketchup screen
not tried it on a single monitor yet

Ah… It’s probably that multiple monitor thing that is snagging you. If you are using two monitors and have some of the dialogs showing on the second monitor, their positions will be recorded in the .json file as such. Then you create problems by using only one display because SketchUp is opening those dialogs based on what was recorded previously. And of course as long as that off-screen dialog is open, nothing else works.

Although I have two displays, I prefer to keep all of the SketchUp dialogs and toolbars on my primary display so I don’t have to worry about this sort of stuff. It’s also a lot less head turning.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.