Text box self-clipping in rotated dimensions?

I’m getting text boxes that self-clip their own content, which is “not helpful”. The top/center/bottom text alignment buttons have no effect. Am I missing something here?

Does it happen with a specific font or all?

It would be interesting to see the LO file. I’ve been trying to induce that sort of thing on my own file and I can’t make it happen.

OT Question: Is it really proper to place dimension over the “part”? I would be inclined to place the dimensions outside.

@Anssi I’m using default Verdana and continues to happen if I switch fonts around.
@DaveR yes perhaps I could move the dim’s to the side but its a large enough plan that pure dimensioning around the perimeter too limiting and potentially confusing, and regardless a lot less of an issue than the “2” reading like an up-side down “7”. The issue persists wherever I put the dim. LO file attached. Problem dim is in lower right corner, but I’ve experienced this issue lots - you can see it happening in every dimension for that part of the plan.
06_PLANS - Copy.layout (14.5 MB)

I’ll add that I’ve tried both grabbing an existing dimension object and copying it and rotating it, as well as creating new dimensions, and problem occurs in both.

Does the clipping show if you export to PDF? Or DWG?
What scale factor do you use on your monitor? Is it larger than 150%?

I’ll be damned. I did not think to check what the export looks like. The clipping does not seem to carry through into the PDF. OY. That’s a little rough, but workable I guess as long as that’s stable behavior I don’t have to remember to check every print. Thanks for pointing that out. Yes, I’m on two monitors with scale factors at 100% and 225% as we were discussing here. I’m starting to think that display is the cause of a range of issues for me, including selection tool difficulties, but I don’t have a solution for it.

Is that issue appearing with that LO file on other people’s machines?

Seems ok to me.
GIF 19-12-2021 11-33-24 PM

I am seeing the same as you Ryan.

I don’t see a way to 'fix" it…but you could “enter” an empty space above dimension text.

06_PLANS - Copy_enter blank space.layout (14.5 MB)

Are you also using bigger display scaling than 150%?

To me it seems now that this is a display glitch related to display scaling. Why, I don’t know but probably if it was easy to make SU support all display scales it would have already been done.

I am not.
No scaling/100%…1920x1080
I am using laptop w/video card in my specs/no external monitor(s).

Thanks for follow up on that as I see you asked that of OP.


@Box and @Charlie_v would you both mind describing what your monitor/display scale settings are? More than one monitor? Display scale settings greater than 150%?

@Anssi yes, one of my monitors is set to 225%. The other is at 100%. But I just experimented with changing the one set to 225 back to 150, then 100, with restart of LO in between, and no change.

2 external monitors running off an old laptop with disabled screen, both set to1920x1080 100% scaling.

Updated above reply w/monitor resolution/scale & video card

1 Like

For completeness I tried other fonts without change/improvement.

so if you are all using 100% scaling and @Box you are seeing same issue as me then sounds like that’s not it.

Perhaps I’m missing something, I thought I wasn’t seeing the issue.

I’m late but I’m not seeing the problem in your LO file either. It’s been written numerous times that SketchUp and LayOut don’t support screen scaling of more than 150%. Try reducing the screen scaling to no more than 150%, do a cold reboot of your computer and see if the problem still exists.


I’m getting a similar issue with text boxes when rotated.

I don’t have much rotated text so I’ve never noticed before.

I use the Lexend font and this is happening with Verdana.

However if I open up a new document using a Layout included template (A3 graph paper) then this does not happen.

Rather than having a ‘clean’ template of my own, I will recycle an existing Layout document deleting the content I don’t need - I wonder if along the way I’ve picked up a ‘corruption’.

If I copy the offending dimension from Ryan’s Layout file and insert it into the Layout template there’s no clipping of the bounding box.