Test version crashes

Dear all, I downloaded SketchUp Pro 2022 and wanted to test it for a month before buying the license. Unfortunately when I start it the button to create new model is grayed out, and when I open an existing model (e.g. the tutorial which is provided) the software crashes ( Crash #282828). Obviously I won’t buy a license before I know that the product really works, so I’m asking you what went wrong and what I need to do to get it running. Regards, fs

Typically crashes on startup are due to graphics driver issues. You list an integrated GPU in your profile. They have never ben recommended for use with SketchUp but you could try updating the graphics drivers–go directly to the Intel site and get their latest drivers. Don’t trust Windows to tell you if the drivers are up to date. Next, presuming your computer is a notebook/laptop unit, make sure it is plugged into mains power. Usually when a computer is running on battery graphics performance is reduced to reduce power consumption. Since your GPU isn’t all that robust for what you are asking of it, you need it to be running at full performance.

Finally, make sure you installed SketchUp correctly. If it’s open, close it. Find the downloaded installer (probably in your Downloads folder) and right click on it. Choose Run as administrator and then choose the Repair option when it is presented.

2 Likes

Hi Dave, thanks for the quick response. I checked and the driver seems to be up to date. So my conclusion is that with my laptop (which is about 6 years old) isn’t suitable any more to work with SketchUp. (I had tried out the free SketchUp 2017 version about a year ago, and now I’d need the Pro version for my new work).

I also tried reparing the installation, but that didn’t help

How did you check that?

Unfortunately with the integrated GPU it was never a great choice for any serious 3D modeling. Many users do get by with integrated GPUs as long as they keep their models in control.

Maybe @colin will have a chance to look up your crash report and give you more of an idea of what’s going on but it might be time to consider a hardware upgrade.

The crash seems to be related to the Intel GPU. What monitors do you have? Does anything change if you run on only the internal laptop screen?

Also check that “Use Fast Feedback” is UNchecked in SketchUp (Window menu>Preferences>OpenGL). SketchUp must be restarted for changes to OpenGL settings to take effect.