TC Import Reference Model produces distorted display

Sketchup and Trimble Connect Plugin are a perfect combination for collaboration and a seamless workflow.

I receive from the Swiss authorities the plot plans in dwg/dxf format. The map Datum is LV95. It is a large coordiante system. The x and y values are all around 2’600’000’000mm and 1’200’000’000mm.

In TC Desktop or TC Web the display of these files is no problem. I re-position the dwg-files, so they are neatly aligned with the sketchup models, which I also store in TC.

WIth the “Import reference model” Option of the TC Plugin, I can also load the dwg/dxf.files into the Sketchup model. The Plugin uses the re-positioning defined in TC Web for dwg files.
This is very cool.

The only problem is, that the display is completely distorted due to the large coordinates. Hence unusable.

The root cause of the issue comes from the dwg import feature in SketchUp which is used by the TC “import reference model” option. The dwg-importer has the option to “keep the origin of model”. This option must be checked (before the reference model import is started), so that the re-positioning defined in TC works as expected as well in SketchUp.

With this option checked the origin of the component, that is created from the imported dwg model, is set to be the orgin of the coordinate system. In case of the LV95 this means roughly 2600km west and 1200km south of the object.
Setting the origin of a component that far away from the bounding box causes the distorted display.

A solution would be, to put the origin of the component to the lower left corner of the bounding box and then move the component to the coordinates (2600km, 1200km)

This could be implmented by providing an option at the dwg import screen.

The result would be the same as with the current “Keep Origin of Model”, but without the distorted display.