T3D setup for plugin

Hi,
I wanted to use Sketchup for exporting a geometry for TRNBuild and installed the T3D plugin; however, it has not appeared in Sketchup’
What should I do

Your profile says you are using SketchUp for Schools. That is a web based version for school children. That version doesn’t have any facility for using extensions. If you are really using SketchUp 2023 Pro, how did you install the extension? Where did you get the plugin? Did you restart SketchUp after installing it? In what menu are you looking for the extension?

Have you tried contacting their customer support? Have looked at their documentation?

If you are using SketchUp Pro please correct your forum profile.

Thanks for your quick response Dave,
I am a PhD student and my supervisor provided me with a license for my use on the laptop.
It is written that the software is SketchUp Pro2023. The extension I tries to install is called “T3D_setup.exe” and it is available in TRNSYS software directory. I installed the plugin and restarted my laptop several times; however, it did not make any differences. I have not contacted anyone yet.
I will correct my profile to sketchup pro. My mistake
In Case you know how to fix the issue, please let me know.
Best
Shams

I looked at the TRNSYS website but did not see anything related to which versions of SketchUp it supports. I found a YouTube video demonstrating it but that showed SketchUp 2019. It’s possible that the software doesn’t support SketchUp 2023 but as I wrote, I didn’t see anything related to that. There is a user forum on their site but I gues I would start with their Customer Support. It’s after 9:00 am so they ought to be in the office by now.

I also couldn’t find anything that indicated which menu the extension should appear in. You might go to the Extension Manager (second item in the Extensions menu) and see if the extension shows up.

Yes. Please do. That information helps us help you but only if you put the right information in the fields.

1 Like

Note that it is distributed as an exe, not the rbz format that is standard for SketchUp extensions. That means that nobody here or at Trimble knows how their installer works. You will have to contact the author directly.

Edit: I too could find no mention of SketchUp or an extension called T3D on their website. I suspect that exe is the installer for their app, not for anything SketchUp. If there is an extension that brings the analysis data into SketchUp it must be from somewhere else.

Edit 2: with some more searching I found that the SketchUp plugin is called TRNSYS3D and is supposed to come with the TRNSYS app. The site has no further info about compatibility or how to install or use it.

That’s what I found and referred to, too.

Have you tried opening the Ruby Console window, closing and then restarting SketchUp? If the extension has compatibility issues they will usually be reported in the console as SketchUp starts. Extensions that include compiled code have to be re-compiled each time SketchUp updates its internal Ruby to a new version.

Another possibility is that their installer looks for installed sketchup versions and puts in the plugin for each one it finds that is known to be compatible. If they haven’t updated their compatibility list the extension won’t be added to 2023 (the extensions for 3DConnexion Space Navigators are notorious for this, I didn’t make it up!).

Thansk @DaveR and @slbaumgartner,
The plugin as you mentioned is TRNSYS3D (everyone calls it T3D). It was my bad not to mention the full name. I also do not know which versions of the plugin Sketchup Pro supports.
@DaveR, I think that it would be better to contact the costumer support team. I also changed my forum profile to SketchUp Pro. I do not know if you can see the attachment to this message, but the plugin adds a toolbar like what I marked. I screenshotted a tutorial for you to see how it looks like


@slbaumgartner, I have not used Ruby Console window yet and I do not know how to use it. I opened it and it is all blank

I did figure out the source for the plugin with a simple search.

I think contacting their customer support will be your best bet.

Thanks for updating your forum profile. Going forward that will help.

Good luck. If you find out anything useful be sure to let us know. It might help someone else in the future.

1 Like

Did you open it then quit and relaunch SketchUp while leaving the console open? If you do that, it will open automatically the next time you start SketchUp. It won’t show anything if you just open it while SketchUp is already running

I just tried it and left Ruby Console open and quitted SketchUp. Opened SketchUp again and it is still blank.
I think the best way to understand the problem is to contact the TRNSYS costumer support team.
Thanks

1 Like

Let’s see if we can get your system to work.

For this demo,

  • I downloaded the TRNSYS Demo installer (trnsys_18_demo_setup.exe) from the TRNSYS website.
  • Extracted the T3d_setup.exe program from the installer.
  • Ran T3d_seup.exe

Which brought up this screen:

The Ruby code for the extension will be installed in the appropriate Sketchup Folder under :
C:\ProgramData\SketchUp\SketchUp 20XX\SketchUp\Plugins.

And here it is in operation.

650x225

2 Likes

Thanks @sWilliams for your response,
I just found the hidden folder PROGRAMDATA and the TRNSYS3D.rb file and .\TRNSYS3D\ folder were available; however, it was for SKETCHUP 2020 while I use SKETCHUP 2023. I do not know if I have to copy and paste all the plugin folder from the 2020 one and copy it into the 2023 one.
If it does work, how do I add it to the SKETCHUP PRO 2023 interface?
Thanks again for providing me the support.

The installer he ran showed boxes to check for the SketchUp version. You might try running it again and checking 2023. You might get away with just copying the files, but there’s a risk of errors if you do. The best practice is always to install fresh copies of extensions for each version so that you avoid the potential hassle.

1 Like

slbaumgartner’s comments are very wise and always encouraged.

In this one case it does appear that all of the Ruby files date back to 2017 and earlier and are not being modified during the istallation process. So, all I can say is try copying the files bewetween directories.

Sketchup looks in the the ProgramData directory during startup and will pop-up the toolbar automatically.

Here are the file and folder names:

362x196

But as always,
There are things we don’t know we don’t know.

1 Like

As you mentioned, there might be some problems by copying and pasting from SketchUp 2020 to SketchUp 2023. When I draw the floor surface, it is shown as roof (reddish) and the roof is shown like ground (grayish). The walls are also inside out (dark yellow is inside).




Besides installing a new version of the plugin, is there any other way to solve the issue?

The plugin in question is not really “popular”.
What is the difference between the old and new versions, mostly only a developer can tell for sure. Ask them.
I don’t know it and I don’t think that it is used by other forum users. For me and 99.9 percent of users here, I don’t think the screenshots and what you posted say anything.

Reading the comments above, it turns out that the developer gives you the option to select your current SU version on the installation. So i guess there is a reason for this. I don’t get what’s wrong with reinstalling it according to your current version of SU.

@sWilliams, @slbaumgartner and @DaveR,
I installed the 2023 version of the TRNSYS3D plugin and I still have the same issue that the floor is shown in red, the roof in gray and the walls are inside out (The dark yellowish surface is inside).
I have no Idea what to do. I think I can change the roof and ground to their proper surfaces; however, in the long run, it would not be efficient. The Ruby Console also sent many errors as follows:

C:/ProgramData/SketchUp/SketchUp 2023/SketchUp/Plugins/Trnsys3d/lib/observers/AppObserver.rb:23: warning: encountered \r in middle of line, treated as a mere space

C:/ProgramData/SketchUp/SketchUp 2023/SketchUp/Plugins/Trnsys3d/stdruby/fileutils.rb:93: warning: already initialized constant FileUtils::OPT_TABLE

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1627: warning: previous definition of OPT_TABLE was here

C:/ProgramData/SketchUp/SketchUp 2023/SketchUp/Plugins/Trnsys3d/stdruby/fileutils.rb:1272: warning: already initialized constant FileUtils::Entry_::S_IF_DOOR

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1284: warning: previous definition of S_IF_DOOR was here

C:/ProgramData/SketchUp/SketchUp 2023/SketchUp/Plugins/Trnsys3d/stdruby/fileutils.rb:1533: warning: already initialized constant FileUtils::Entry_::DIRECTORY_TERM

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1567: warning: previous definition of DIRECTORY_TERM was here

C:/ProgramData/SketchUp/SketchUp 2023/SketchUp/Plugins/Trnsys3d/stdruby/fileutils.rb:1656: warning: already initialized constant FileUtils::LOW_METHODS

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1686: warning: previous definition of LOW_METHODS was here

C:/ProgramData/SketchUp/SketchUp 2023/SketchUp/Plugins/Trnsys3d/stdruby/fileutils.rb:1662: warning: already initialized constant FileUtils::METHODS

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1693: warning: previous definition of METHODS was here

test(m²)

C:/ProgramData/SketchUp/SketchUp 2023/SketchUp/Plugins/Trnsys3d/templates/

c:/ProgramData/SketchUp/SketchUp 2017/SketchUp/Plugins/Trnsys3d/templates/

C:/ProgramData/SketchUp/SketchUp 2023/SketchUp/Plugins/Trnsys3d/lib/…\templates

Checking for update…

@dezmo Thanks for your comment. I did not see you comment and I sent another post. It seems that the problem continues to exist even with the new version.
I also contacted the plugin providers; however, I have not heard back from them yet.
Hopefully, one will be able to help me sort this out

The Console error shows there is a problem with Trnsys3d plugin. So better to wait for dev response…

1 Like