Surfaces suddenly disappear on large models

I use Sketchup Pro to convert house plans in PDF form into 3D models. Most of the time is works great however when I come across a large property I regularly run into a problem where I’ll copy something from another file (like a plant or bit of furniture) and suddenly most of the walls disappear (see the attached image).

When this happens I save the file and quit Sketchup. Then I restart it everything is back to normal, I can then paste the object in and carry on working… until the next time I go to copy something from another file.

Is this a memory issue? It used to happen on SU2014 also. I’ve got 28GB of ram in the iMac I’m using and nothing else causes it to run out of memory (even the large photos I work with in PS).

Looks like a graphics card issue. You might try disabling Hardware Acceleration in SketchUp>Preferences>OpenGL.

Thanks for that,

I’ll have to try that when I’m back in the office. Won’t turning off OpenGL slow things down a lot though? I’ll have to try opening the same model on a Windows computer I have and seeing if I can replicate the fault.

Best regards

James Ball

you might try changing between view modes…

I occasionally loose textures after a copy paste, but they return if I select monochrome, and then back to texture with shading…

orbiting and zoom extents etc… does not work when this will…


You won’t be turning off OpenGL. Only turning off Hardware Acceleration.

Don’t be surprised if you find different results on a Windows computer. Different graphics card and different GPU drivers.

John’s suggestion may help to reduce the problem.