Surface Book 2 GTX1060/UHD620 crash workaround


#1

Just did a brand new installation of Win 10 Pro on MS Surface Book 2 15” (i7 GTX1060), SU2018.0.16975 crashes every time after template selection. I found a workaround by disable Intel UHD620 graphic in device manager, which force laptop use GTX1060 only. Is this a know bug? Any fix on the way? Thanks


#2

You shouldn’t have to disable the Intel graphics, just go to the 3D application settings in the Nvidia control panel and set Sketchup to only use your Nvidia card. Also make sure that your Nvidia driver is up to date. New laptops often ship with outdated drivers.


#3

Once you reengaged your Intel graphics, try r-click on SU desktop icon. You should have an option to choose the higher performing NVidia card for SU from the context menu.

It’s not a bug. It’s about laptops managing resources.


#4

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.