SU Pro 2019 not loading properly and Layout 2019 crashes


#1

I just installed on SU Pro 2019 on a brand new Windows 10 Microsoft Surface Book 2 and have two issues:

  1. When opening SU 2019, the “workspace graphics (i.e. no axes, sky, background, Marc)” are not showing. This goes for opening a new fresh file and a file previously created in SU Pro 2017. With the previously created file, you can see the scene tabs and layers, but can’t see “workspace graphics” even when selecting a scene tab.

  2. Layout crashed upon startup when opening a file that was preciously created in Layout 2017.
    In this case, I can open a new fresh layout file and it seems to work.

thoughts?


#2

For me it was a problem with scaled drawing groups.

I was able to isolate the offending groups and un-scale/un-group them, save the file (in 2018) and then was able to open in 2019.

The SketchUp team was able to confirm later that there was a particular problem with the groups.

I don’t know how to link to it but see my earlier post Layout 2019 Crashes


#3

I have two videos of the condition I mention in #1. but they are 5-6 MB which is too large to upload here. (I already compressed the file) I’d be happy to share them if someone can help me get them uploaded or linked.


#4

Put the files on a file sharing site such as Dropbox or Google drive then post the link in the forum.


#5

Here are links to two videos of conditions #1


#6

No one out there to help me with this? Should I post/email/call somewhere else? It would be nice to get it working and take it for a full spin.

“patiently hoping for help”


#7

yes well proper support would help not just kind volunteers. should be able to raise a ticket


#8

Post your video in the “.gif” format.


#9

should be able to right click (on a pc) on the link (link being the video screen looking things) and copy address, then past into broswer…they are links to video on Dropbox.

work ok?


#10

what format is the video that is on the dropbox platform? You should be able to right click on the file listing in DB, menu should give an option for a link to copy. That is the link to put into this forum.
Or you could re-create the video using LiceCap then upload that to the forum.


#11

That is what I did for the links above, but this forum is changing the links to the video screen looking things.

How about as hyperlinks? Do these work:

SU 2019 not loading correctly movie 1

SU 2019 not loading correctly movie 2


#12

Without seeing your video I would guess that your setup is using the wrong graphic card.
Check in Window/Preferences OpenGL and see if it is using the Nvidia card.
Also check your graphic drivers. You can also turn off Use fast Feedback and see if that helps.
Edit: I just read your OP and I now see you are doing this on the surface, they have been known to have issues. I’ll bet turning off use Fast feedback in opengl settings will make it work, but it still means the graphic card isn’t really supported.


#13

Box,

You were absolutely correct. Once I turned off fast feedback, it was fixed.
I was having issues with SU2017 a few weeks ago when I installed it on this Surface Book 2. After updating the graphics card driver, SU2017 was working.

What is it with SU and these Intel Graphics cards??

Thank you much for your help!
now to go sort out this Layout crash issue…


#14

Sketchup relies heavily on the graphic card and Integrated intel cards are known to be fairly weak in their openGl capacity.
Always look for dedicated cards when you can, nvidia by preference currently.
One version of the Surface comes with an Nvidia card. If it’s a new surface, perhaps you can exchange it for the more expensive one with the Nvidia card.


#15

Bummer. I was unaware that these Intel graphics cards and SU don’t play well together. My return grace period for the Surface ran up 10 days ago…9 days before the release of SU2019…when I noticed this issue.

Now I have to decide if it’s ok to continue running SU with fast feedback off for years to come, or try to sell this Surface (not easy) and get a different one.


#16

Here’s a snip from the hardware recommendations.


#17

Thanks!!


#18

Hi Box.
I also have the same problem with PRO, just installed, and no visibilty, having a new PC, but with Intel UHD graphic 620.
You mention it could be fixed by turning off “Fast Feedback” -how do I do that ?
Kind Regards, Kjell


#19

Window menu>Preferences>OpenGL, uncheck “Use Fast Feedback” and restart SketchUp.

I also recommend that you go to the Intel website and look for the latest graphics driver for the UHD 620 graphics.


#20

Thanks Anssi !