SU Make license-accept button off screen, impossible to click on windows 10 laptop


#1

On a laptop, the initial license-challenge screen is too high, and the button which must be pressed to continue is off-screen and can not be clicked. Scroll-bars are not enabled, and the Alt-spacebar menu does not work so arrow-keys can not be used to move the window. During the trial period, the Task Manager can be used to forcibly close the startup screen, but after the 30-day trial you must click the button to accept the SU MakeTerms, and doing so is impossible; so SU becomes completely unusable on that computer (without a Pro license).

SCREENSHOT: http://abhweb.org/jima/su_nobutton.png

STEPS TO REPRODUCE:

  1. Use a Virtual Machine (or real computer) which is not yet licensed.
  2. Change the screen to 900 pixels in height (to match common laptops).
  3. Start Sketchup

RESULTS: The license-challenge screen appears but the button to continue is off-screen and can not be brought into view.

EXPECTED RESULTS: Window should either size itself to match the screen, or enable scroll-bars.


#2

You can attach [copy+paste] images directly into your posts, so there’s no need to put others who might otherwise help you to extra [unpaid] work…

I recall that having an out of date Internet Explorer installation might be a culprit.
Your IE should be v11 ?

Can’t you change your screen resolution to suit ?


#3

SU does not run in a browser, so the IE version is not relevant.

Changing screen resolution does not help because it can’t be changed to have more pixels than the physical screen (900 px high, in my case), and the SU license-challenge window is sized larger than that so it is partially off-screen.

(The scroll bars you see in the screen shot are not attached to the SU licence challenge screen, but to the SU app window which is behind it)


#4

There, sir, you are mistaken. The window in your screenshot is indeed dependent on IE (no matter what you use as your default browser) and Internet Explorer needs to be up to date.


#5

AFAIK windows 10 auto-updated iE without user intervention. How can I determine if it is up to date? On my system IE says it is
Version: 11.545.10586.0
Update Versions: 11.0.34 (KB3175443)


#6

for zooming in a browser window hold down CTRL and press +/- keys or spin the mouse wheel.


#7

CTRL- +/- does not zoom the window, but changes the text font sizes. The un-clickable button remains off-screen even if the text is zoomed out to a tiny size.


#8

close the tab “Learn” sothat you can see the tab “License” and click in it to set the focus, zooming by shortcut should work than.


#9

Ah! That let me see the License tab, which does scale with font size. Thanks very much.

But that revealed a new problem: The “License” tab displays no options except “Add License”. There is no way to get to Sketchup Make (e.g. after double-clicking an existing .skp file). I’m guessing the “Continue to Sketchup” button is somewhere at the bottom of the “Learn” tab where it can not be seen or clicked.

So it is still necessary to kill the challenge window from the task bar to get to the application.

(I had previously gotten past the 30-day “Accept Make Terms” challenge by randomly pressing F4 and clicking until I accidentally clicked the required but invisible button)


#10

No. There is no button to just start SketchUp Make. Once the 30-day trial period for SketchUp Pro has passed, it’ll revert to Make.

The “Welcome to SketchUp” window will always be displayed unless you buy the Pro license after which you can disable it if you wish.


#11

We aren’t communicating very well. The “Welcome to Sketchup” window has no way (that I can find) to make it disappear so the application is visible. Please look at the screen-shot above. Thanks.


#12

The window is too big. Drag it up… the button is in the lower right corner.


#13

You are missing the whole point! There is no way to drag the window up. It is already as high as it can go (at the top of the physical screen). The button “in the lower right corner” can not be made visible, so it can not be clicked.


#14

You’re not trying hard enough. Click Add License. Then hold down shift, hit tab. Then hit space bar.

New record: 2 mic drops in one day.


#15

Easier Solution:

  1. Right click Windows desktop
  2. Select “Screen Resolution”, “Portrait” Orientation, “Apply”
  3. You will now see all or part of the bottom of the license-accept button. Click it.
    ( Mouse controls will be 90 degrees off - move mouse left moves cursor down, etc.)
  4. Alt+Tab back to Screen Resolution window, select “Landscape”, “Apply”.