SU Make crashes after startup at various intervals

Hi
My Sketchup 2017 Make is crashing on one of my machines within a brief interval after starting.
The interval seems to vary between 2-10 minutes before crashing and occurs even though I am not using Sketchup.

  • The SU window can be in the foreground (active window), or in the background while I do something in Chrome or Excel.
  • The crash occurs with my model, but also with a blank file created at startup.
  • I have run Sketchup Checkup and it passes.
  • Sketch* up Make 2017, 64 bit
  • All Extensions disabled via Ruby Console command: Sketchup.plugins_disabled = true
  • Windows 10
  • All Win10 power settings set to max performance and laptop is running plugged in
  • No Win10 Desktop Background changes occur
  • No Win10 screensaver is enabled
  • Thinkpad T520, 8GB RAM, 377GB SSD with 263GB free
  • Nvidia NVS 4200M GPU, driver ver 22.21.13.8205, 2017-05-21
  • Occurs on Internal Laptop display or external monitor

Bug Splat Report was sent, MFA=ntdll!00107580

Does anyone have any idea on what else I might do to fix this?
SU used to work on this machine several months ago, but obviously something has changed!

Thank You,
…Patrick

One common reason for crashes like this has to do with integrated Intel graphics adapters and their drivers. Although the NVS 4200M GPU isn’t a real high-performing graphics card, you should make sure SketchUp is using it and not the intergrated Intel.

Another common reason is incorrect installation. Correct installation of SketchUp requires right clicking on the installer and selecting Run as administrator while logged into Windows under your normal user ID. If you installed it any other way, it won’t be installed correctly.

Dave
Thanks for the quick tip!
Yes, I have set the Nvidia 4200M GPU to run, and verified that within SU.

As for the Admin privileged install…I can’t recall if I ran it that way BUT my userid does have Admin privileges. Hoiwever, I will certainly remove and reinstall it the way you suggest to see if that fixes it…crossing my fingers.
Thanks,
…Patrick

No need to uninstall SketchUp. Quit out of it and find the installer. Right click on it, choose Run as administrator and when offered the option, choose Repair.

Having admin rights is not the same as choosing Run as administrator.

Dave

Well, I ran the uninstall before I saw your 2nd message, and then did run the installer with the RunAs Admin like you suggested. Installation went fine.

I was hopeful, but it crashed again.
The SU OpenGL Details shows Nvidia is the Vendor, and GL Version: 4.5.0 NVIDIA 382.05

Still stumped here,
…Patrick

When it crashes, are you getting BugSplats and are you submitting them to Trimble with identifying info so they can get back to you? It would also help to give a crash report number here (when you submit a BugSplat you should see a browser reply page with the crash number). The Trimble staff can look up the report(s) given adequate identifying info.

Hi
Yes, I have submitted numerous BugSplat reports with my name and email…and a brief description of the problem and steps I have taken to try and identify my situation. My most recent BugSplat Crash Report #1384967 occurred after I had reinstalled using RunAs Admin.

I just ran into another BugSplat, Crash Report #1385025, on a brand new session that I had done nothing in it since starting it while I was reading and responding to your message.

It’s very repeatable, but with various intervals of working before it crashes. I suspect it is trying to do something, like login to Trimble, or maybe my system does something at various intervals that causes it to hang.

Another note: it is not like I am doing something in SU when it crashes…I am not drawing objects or orbiting the model, or running any specific command. It is presumably in an idle loop waiting for user actions or inputs from the keyboard or mouse.

While I have been submitting multiple bug splat reports for over a month I have not been contacted by Trimble. I’m not sure what gets onto their radar so this problem may be too low on their list to help with. So I am grateful for anyone else who may help out.

Try turning off Autosave, sometimes that can clash with an extension. If it stops crashing it gives a clue where to start looking for the issue.

Hi Box,
Good idea with Autosave, but I still crashed with Bug Splat #1385113. I did disable Autosave, I also disabled the Check for Update option, and I had previously disabled all Extensions with Ruby Console: Sketchup.plugins_disabled = true

So I remain stuck on this problem.
Thanks,
…Patrick

I think at this point you need to wait until someone on the SketchUp team has a free moment to look at your Bug Splat reports if they can.

Dave
Thanks for the advice here.
As a noob, I’m not clear if I need to do anything else to bring this up to the SU Team.
I’ve been sending reports for over a month now and have not gotten any response. :frowning:

Thanks,
…Patrick

No. There’s nothing else to do. Remember, as a Make user you can’t expect tech support to contact you so you are kind of stuck with us trying to help you.

I understand, and while I won’t expect any help from SU I can still cross my fingers. :slight_smile:

1 Like

I wonder if some process on your machine related to SU is running away with memory? I know on Mac (not Windows) that 3Dconnexion drivers for their SpaceMouse and other 3D mice can run away - it happened to me. The symptoms were similar - normal behaviour in SU until memory was exhausted, then either freeze or bugsplat.

Use Task Manager to ave a look at memory use in the period between starting SU and getting the bugsplat to see if this might be happening for you.

1 Like

I looked over one of the bugsplats with a QA engineer, and at the time of the crash bugsplat was still waiting to get information from a file, to then know what was going on at the time. That never completes, suggesting there are files that cannot be read.

Which would point at a general Windows file permission issue. The engineer suggested using process explorer to watch what file errors are happening while SketchUp is running. Here’s an article on that:

https://medium.com/@ppatali/sysinternals-tools-process-explorer-and-process-monitor-6252b919e5fb

John
Well in my case I see no run away memory usage. I used Task Manager and Process Explorer and it showed no change in memory usage during the run time of SU. Main memory was at 4.5GB used out of 8GB. The memory used for the SU process itself did not change during its run time.

Next I will investigate the file access suggestion from Colin.

Thanks,
…Patrick

Glad to hear that - because it can be difficult to fix. At least you’ve eliminated one possibility.

Well, in my latest Bug Splat # 1386392 I recorded that the crash happened again, while PC had just rebooted, and the SU process had just opened an empty model file and sat idle for about 3 minutes. Using Process Explorer I did not notice any unusual CPU, GPU, or memory usage, nor did I see any issue with the list of files and keys in the procexp output.

Still searching for an answer here…this is definitely wierd. SU works on my other PC just fine…but this PC is consistently causing SU to crash after a brief interval following startup.