SU 2020 crashing when hiding line

Sketchup crushes when I select an edge and try to hide it from the info panel hide button. I have already sent the error report. Any suggestions?

Share the .skp so we can look at it and see if there is anything wrong.

When you installed SketchUp, did you right click on the downloaded installer and select Run as administrator?

It happens even if I start with a new file and make a rectangle … yes Dave, I have two separate accounts, on my laptop, one as an administrator the other as a simple user.
I have never had a problem before.

I believe the error is related to the installation of a plugin not compatible with SU2020. I’m talking about ToH’s 3D Gridlines … possible? I have already removed it but the problem continues.
Maybe I should try reinstalling Sketchup … No, the problem remains

It may well be an incompatible Plugin…

BUT when you install any complex app like SketchUp it must be installed properly, otherwise all kinds of unpredictable problems can manifest themselves…

You normally do not need to uninstall SketchUp to fix things…

Whilst logged in to Windows as your usual user [the one that will use SketchUp] Windows user-account [whether of not that user has admin-powers is unimportant]…
Ensure that SketchUp/Layout are both closed.
Find the SketchUp installer’s exe file - normally in your Downloads folder ?
Select the exe file’s icon, right-click > context-menu > “Run as administrator”
When prompted choose “Repair” [for a fresh installation it’s “Install”]
When it completes restart SketchUp to see if it’s improved…
Any personal Extensions you have installed should be unaffected…

Installing in any other way - e.g. by double-clicking the exe file to ‘Run’ it - is a recipe for a problem later on…
Having admin-powers is not enough.

2 Likes

Thanks TIG, I just tried but the problem remains. I have two accounts: the first I only use to install software and make updates. I use the other to work. So i make the repair from the first account which is not the same I work with. Am I wrong in these steps or could the damage be more serious?

There is no damage, but it is not the same. The repair from within your first account will only affect the read-write permissions of that account, but SketchUp needs access to a variety of folders while working with the ‘work-user’ account. While setting this up, it will most likely take the current logged-in user to account.

I guess some of those folders are ‘temp folders’ that SketchUp uses to iterate the model and its changes, so if something isn’t setup right, strange things can happen.

Since you are both Admin and User, it actually does not matter how privileges are set up, since Windows will prompt to provide the credentials of the Admin account when trying to install or repair. No need to log out of your User account and log in as Admin to do some installing.
But SketchUp will, so you have to be logged in as the ‘Work -user’.
.

1 Like

I’m getting constant crashes using basic functions like drawing lines and extruding faces. I saved down my file to 2019 and I’m not having any issues.

When you installed 2020 did you right click on the installer and choose Run as administrator?

I am the administrator on this computer. I’ve never had to install Sketchup as an administrator before. Is that a new issue with 2020?

I’ve been using it to create models but it started almost immediately to start crashing.

That’s not the same as using Run as administrator.

No. This has been a thing for a long time. If you didn’t have problems before, you were lucky. There have been numerous reports of weird problems that were solved by properly installing SketchUp. There are so many of them that I won’t bother posting links. a simple search will turn up more of them than you’ll need. If nothing else, it wouldn’t hurt to repair the installation. Find the downloaded installer file, right click on it and choose Run as administrator. Then when it is presented, choose Repair.

If the graphics card you list in your profile is correct, make sure its drivers are up to date and make sure it is set up to be used by SketchUp.

Thanks Dave, I’ll try that.

I tried the repair but it couldn’t find Sketchup 2020.msi and failed. I ran a search on my computer and couldn’t find the file. How can I get it?

You can download it here
https://www.sketchup.com/download/all
You’ll have to log in to your Trimble account before you’ll see the download links.

If you want to try the MSI version directly, it’s here:

https://www.sketchup.com/sketchup/2020/SketchUpPro-msi

It’s continued to crash. I’m uninstalling it and I’ll restart and try again.

This could require a fresh install of the OS due to permission issues.

I had to do a reinstall of SKP 2020.