Styles don't transfer from one file into a collection!

styles
sketchup
collections

#1

I cannot transfer styles from one file to another file. This has never worked for me in all the years I use sketchup pro.
Please help me fix it. The styles will not drag from the secondary selection pane into the new collection I have set up.
I grab the style and it disappears when I try to ‘drop’ it into my new folder location for saved files…it means I need to remake my styles every time or else save off an existing file…not very handy.
I use sketchup every day, 99% of the time it is fantastic.
S


#2

Where is the folder for the new style collection located?


#3

I just saved into a folder I set up. Does it need to be within the Sketchup Library?
I use a 2015 iMac by the way. Thanks for responding.
S


#4

Where did you put that folder? The folder needs to be someplace that isn’t locked up by the OS. Make sure its set up so you can write to it.


#5

It is in my Dropbox, I can write to it.


#6

The penny drops. Make a folder on your desktop or in the documents folder and try that. It’s not a good idea to try to save directly to Dropbox. This is the first time I’ve seen anything about someone trying to save styles to Dropbox but lots of users have reported issues with saving SKP files directly there.

If you want to access those styles from another computer, synchronize the local folder to the one in Dropbox and then copy it to that other computer.


#7

Hi DaveR
I have just tried that and the same issue arises, namely the style doesn’t drag into the new folder.

I have also done the following advice previously received from Sketchup support with no success.

"Thanks for your note. There may be an issue with the disk permissions on the computer that is preventing SketchUp from saving the Style information. To repair disk permissions, please visit this page:

  1. Restart your computer.
  2. Open a Finder window.
  3. Click Applications.
  4. Click Utilities.
  5. Double-click Disk Utility.
  6. Select your hard drive.
  7. Select the First Aid tab.
  8. Click Repair Disk Permissions.
  9. Please repeat step eight until you no longer see new errors during the repair.
  10. After the permissions are repaired, exit Disk Utility.

If repairing disk permissions doesn’t do the trick, you may have an extension installed that is causing the issue that you described. To test if this is the case, I recommend reviewing the following article to disable the Ruby plugin interface:
help.sketchup.com/en/article/1700320
If disabling Ruby resolves the issue, then I recommend disabling or uninstalling any recently installed plugins.
Regards, The SketchUp Team"

I have also disabled all my plugins to see if they were affecting things.

A mystery…


#8

what works on my iMac is this…

john