Spatial Lag after Undo in an Interactive Tool

Something that puzzles me, as I am not sure this is just for me or other users see the same…

When you are in an interactive tool, say Line tool, and that you perform an Undo via Ctrl-Z, you need to slightly move the mouse to resume the tool. This is what I call the ‘spatial lag’.

  • in SU2022: you just need to move the mouse by 1 or 2 pixels
  • in SU2023.1, the spatial lag is much bigger, around 10-20 pixels

Here is the video illustrating what I describe

Am I the only one to observe it ?

As an additional information
  • This happens with both Undo and Redo
  • This happens with native Sketchup tools (Line, Move, etc…)
  • This happens with plugins based on an Interactive tool (for developers, the onMouseMove event is not received until the user has moved the mouse sufficiently)
  • This is not a time lag. Waiting for seconds or minutes would not change the behavior
  • If you zoom with mousewheel, then this wakes up the tool
1 Like

Hmm, I haven’t felt it yet, and I just tried on my mac, I still have the “old” behaviour.

for info, mac mini M1, Ventura 13.6
My anti-aliasing is at 0x and my fast response is off.

edit oh yeah, and SU 23.1.341

Capture d’écran 2023-10-20 à 12.18.47

I should have said this is on Windows only. On My Mac, the spatial lag is just 1 or 2 pixels.

1 Like

I thought so, and just before lunch, I tried on the PC and yeah, same as you show, it takes some distance.

I guess QT is acting up again ?

I’m not seeing a delay like you describe but sometimes just Undo seems to lag a little bit.

It’s not a time delay. It’s a pixel distance?

Ah ha! I do see that. I just tried again and I was able to repeat it, too. Hadn’t noticed it before but I don’t need to use Undo very often while drawing edges.

OK. Thanks.

So, I am not the only one…

It must be something that appears with the Qt migration or the reengineering of the graphic engine in SU2023.1.

Personally, I don’t understand the logic of having to move the mouse so much to resume the tool. It gives the impression that Sketchup is frozen.


It could be unrelated but I’m getting a similar delay with your FredoSketch Move tool Fredo and also with Curic’s DIO2 Trowel tool.

It is perfectly related. It seems to affect all interactive tools, whether native to Sketchup or plugins.

It seems more related to the Undo/Redo, which requires that the user moves the mouse sufficiently to resume the mouse capture.