Spacemouse with Sketchup 2018?

Upgraded to SU 2018 Pro yesterday, updated my 3Dconnexion Spacemouse driver, but it does not work/is not listed in Extension Manager. What am I missing?

They haven’t updated their driver yet to recognize 2018 so you need to manually copy the files over from 2017 to 2018.
On win the files can be found at C:\ProgramData\SketchUp\SketchUp 2017\SketchUp\Plugins
You need to copy them to the same location in 2018.
You may need to create the folder.

1 Like

Problem solved! Thanks, Box!

Hi Guys,

I followed your instructions, but the only plugin folder I see is “ifcplugin” and the 2018 version has the exact files in it as the 2017 version. I’m not sure what I’m missing/doing wrong. Plus, I’m new to using Pro. (I just started the free trial 2018 from Make 2017)

Any suggestions would be greatly appreciated!

My first suggestion would be to re read the file location I posted above.

I have C:\Program Files\SketchUp\SketchUp 2017\ifcplugin and that folder has the exact same files as the 2018 location.

is not

look again…


That path doesn’t exist on my PC, I only have “Program Files” and “Program Files (x86)”, and only the first contains any Sketchup data. There is no “ProgramData”. I hope you don’t think me obtuse. I do appreciate your help!

It is there. It is a hidden folder. Turn on the visibility of hidden folders in your folder options or type “%programdata%” without the quotes in the Start menu search box or the Search application.

1 Like

That worked! Thank you so much for your patience - I couldn’t have done it without you!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.