Spacemouse Pro Buttons to Modifier Keys

Using Sketchup 2021 Pro on a MacBook Pro w/Big Sur. I am having trouble mapping the Command {Modifier} Keys (Command, Option, Control, Shift and ESC) to my 3Dconnection SpaceMouse Pro Wireless. This is a brand new device for me, but I am a long time SpaceMouse Compact user. I am able to use either SpaceMouse while running Big Sur, so that is not my issue. I can also map the two buttons on my Spacemouse Compact to Modifier keys (I use Space and Option). I can map all of the SpaceMouse Pro Wireless buttons to other keys (move, push/pull, etc) but not to the Modifier keys? None of the 15-buttons work when mapped to SpaceMouse Pro Wireless. The preferences window will allow me to assign the buttons, but they have no affect in Sketchup. I have uninstalled the driver and re-installed. Is or has anyone else experienced this?

Hi @maynardjd
I’m using exactly the same setup.
SU2021
MBP
SMPW (can’t map ModKeys)
SMW(can’t map ModKeys(
CMPW (all good via Bluetooth only) not sure about mapping ModKeys, i don’t wanna try, just in case something goes wrong.

i see you managed to map on Space mouse Wireless- how ?
I’m having the same issue on both.

upgraded firmware on all devices including Bluetooth receiver using Windows pc, still no Mod Keys

tried workaround creating Macros (Shift+button… etc) nothing- looks like it just ignores ‘‘Shift’’

contacted every source i know - no answer.
looks like everything is on standstill.

That is really weird! I know this does not help for people who already have a Spacemouse Pro, but the Spacemouse Enterprise has modifier key buttons that are mapped by default. Just info incase anyone comes across this thread and is deciding what version to grab.

I think there is discussion of this issue on the 3DConnexion forum. They claim the latest beta driver has a workaround.

Edit: 3DConnexion claims the reason is that Apple discontinued “kernel extensions” in Big Sur so they have to develop a new way to feed simulated keypresses into the event stream. To be blunt, that strikes me as exposing the fact that they don’t pay much attention to Mac. Apple said even before the release of Catalina that kernel extensions were going away, and Catalina warns during boot when an app loads extensions. 3DConnexion have been sitting on their hands for more than a year (or hoping they could call Apple’s bluff and find extensions still in Big Sur).

Hi @TheOnlyAaron
SpacemousePro ModKey buttons are mapped by default too, they just do not respond, even you try to remap ModKey to any other buttons.
@slbaumgartner yeah i’ve seen that post, totally agree.

Latest i’ve found - That another 3DXware beta update is coming 15th of Jan.

That’s what they say

Blockquote There are two issues we’re currently looking at: modifier key emulation (Shift, Control, Config, Cmd) and a performance problem with Google Earther.

For the modifier key emulation, we have an interim solution available now, allowing some functionality but not as fully as in macOS 10.15 and older. We aim to restore this feature at some point but this is likely still months away, not days or weeks.

For Google Earth, we have not yet determine what is causing the performance issue and it seems to be isolated to this application.

So few months huh :thinking:

I corresponded with 3dconnection a week or so ago. They told me that they hope to have the driver this month. I’m not holding my breath. I’ve also been holding out on loading Big Sur because I’m so addicted to my space mouse. I guess I’m just gonna have to bit the bullet and download the Beta driver.

1 Like

Let us know how it works out!

Hi,
I have the same problem.
Mac Mini M1, Sketchup Pro 2021, Big Sur MacOS.
3D Connexion driver Version 1.2.0 (1.2.0.192)
The Shift, Options and Command are mapped in the driver, but none of them work.
This was kind of the point in investing in the Pro version of the space mouse, so this is disappointing.
Did anyone found a work-around?
I’ve logged a query with 3DConnexion Support.

I’ve also contacted 3DConnexion, but with no response. I hope they fix this soon. It’s been too long.