Some browsers not showing embedde model


#1

When I embed a model onto my website it works like a clock in Safari but shows an error in both Firefox and Crome (I’m a Mac user)
Please check this link: http://www.tcwaterstop.dk/index.php/dj-catalog-under-terraen/item/123-bundplade-dobbelt

and have a look at the tab “VIDEO / 3D”

FIREFOX / CROME:

SAFARI:


#2

I recently noticed this too (in this forum, where you can also embed models).
https://3dwarehouse.sketchup.com/compiled.js?2a9b9bb line 1013: Error: Permission denied to access property 'page'


How to embed 3D Warehose models directly in this forum?
#3

I got the same error in Safari. The Web Inspector reported the cause as the following:

[Error] Failed to load resource: the server responded with a status of 403 (Forbidden) (GetEntity, line 0)
[Error] Blocked a frame with origin “https://3dwarehouse.sketchup.com” from accessing a frame with origin “http://www.tcwaterstop.dk”. The frame requesting access has a protocol of “https”, the frame being accessed has a protocol of “http”. Protocols must match.

Hg (compiled.js, line 1013)
(anonymous function) ([native code], line 0)
(anonymous function) (compiled.js, line 259)
handleEvent (compiled.js, line 121)
wh (compiled.js, line 129)
vh (compiled.js, line 129)
xh (compiled.js, line 131)
dispatchEvent (compiled.js, line 134)
fz (compiled.js, line 242)
(anonymous function) ([native code], line 0)
handleEvent (compiled.js, line 121)
wh (compiled.js, line 129)
vh (compiled.js, line 129)
xh (compiled.js, line 131)
dispatchEvent (compiled.js, line 134)
dk (compiled.js, line 230)
fk (compiled.js, line 232)
Bq (compiled.js, line 231)
Tu (compiled.js, line 231)
(anonymous function) ([native code], line 0)

#4

I found the problem: my model was “private” - when I made it “Public” it worked in Firefox. Haven’t tested with Crome yet.


#5

Works fine in Crome.


Hilsen herfra