Solid Inspector: How to fix "Surface Issue" with Model?

5HalfxHeight.skp (72.8 KB)
After several hours…need help with something obvious. :grimacing:
I think the issue is “Hidden Geometry” introduced in the modeling process…What are the “dotted lines” in the model?
If I delete the “dotted lines” faces disappear…How to clean up surfaces/faces to keep Solid Inspector happy :partying_face:

Update…Figured out what “dotted lines” are in Entity Inspector but still don’t know how to clean up issues with Solid Inspector?

The diagonal lines are required to generate the faces because the perimeter edges aren’t coplanar. Go back to the fundamentals of planar geometry for that. The dashes indicate those edges are softened/smoothed. they won’t show if Hidden Geometry is turned off.

In order to fix your geometry for Solid Inspector, you need to close the big hole.
Screenshot - 8_23_2021 , 7_13_26 AM
Use the Line tool to connect diagonally opposed corners as below.
Screenshot - 8_23_2021 , 7_13_52 AM

In order for a 3D shape to be considered solid every edge must be shared by exactly two faces. So no stray edges (no faces), no holes in the surface as in your model (one face), or internal faces (three of more faces).

Also correct the face orientation. Most of the faces show the blue back sides out. You should have only white front faces exposed in the 3D shape.

1 Like