Solid inspector and fixes?

Hoping to CNC this molding into oak (via Vcarve)…

I only need the top .375" (where the molding profile is)- I will cut the "clover shape w a larger straight bit afterwards… My strategy was to use Solid Tools to remove the bottom, leaving the target molding…

(Separately, I used the “Dave method” for fixing the face issues after the FM tool operation- does the line towards the front mean I didn’t do it right?)

Any other ideas for isolating JUST the molding at the top?

Thanks!

Clover 8 24 21.skp (8.2 MB)22in clover 9 4 21.dxf (19.8 KB)

Like usual, it would help if you upload the .skp file.

Why not use the Line tool to connect the lowest corners of the molded edge along the flat side of the part, then just delete what is below?

Uploaded as edit thanks!

Was able to delete per your suggestion thanks!
Still does not look like a solid.
Would you recommend reimporting DXF and redoing PushPull/ FM / Dave method to see if this resolves this?

There are a couple of reasons why you can’t use the Solid Tools to trim this. The first tow is you have the component double wrapped. A component inside a component. The other is there are holes in the surfaces. The dark “lines” are the borders of those holes and there’s matching ones on the other side.
Screenshot - 9_4_2021 , 6_58_49 AM

If you fix those holes and explode the unneeded component container you should be good.

Now that I can see your model I see the molding profile is only 0.370 in. tall but you say you want 0.375 for the thickness. Another option that wouldn’t require the component to be solid is to draw a couple of edges on the flat edge face and then use Ctrl+Push/Pull to push the face through. Then select the geometry and Intersect Faces>With Selected followed by deleting what isn’t needed. Here the upper of the two edges on the flat end is 0,375 down from the top face.

After Ctrl+Push/Pull

After Intersect Faces, waste selected for deletion.

And waste deleted.

It would still be best to fix the holes in the surfaces to make it solid.

By the way, I know this has been brought up previously. Turn off Length Snapping.
Screenshot - 9_4_2021 , 7_08_39 AM

It would also be a good idea to purge unused stuff from your model.
Screenshot - 9_4_2021 , 7_21_43 AM
And make sure you are using tags correctly. You have a fair amount of geometry that has been tagged. ALL edges and faces should be untagged.
Screenshot - 9_4_2021 , 7_35_01 AM

No. Yours isn’t solid. You could start over. I just fixed it by filling in the missing edges and faces.

Can’t believe this is the first I’ve heard of the Length Snapping issue, but I just read that its a giant sore spot for users- I’ll turn it off thanks!

In the future, are these hard lines the dead giveaway the FM operation was buggy, and will require fixing before exporting to CNC?

Not a an indication that Follow Me was buggy. More likely something odd in the way you created the profile or something else. Zoom in close with Hidden Geometry turned on. You can see that there are edges that divide what should be single faces.

The short little edges down lower on the profile are considered as coplanar edges so they aren’t softened unless you turn on Soften Coplanar in the Soften Edges.

As for fixing before exporting for the CNC, if those hard edges will be considered toolpaths, by all means you’ll want to clean up the model. My preference is to keep the components solid in my models even if they aren’t being used for CNC or 3D printing. Solid components are clean and much easier to work with that non-solid components.

Brand new territory for me: fixing solid models at this level…
Is this part of the process you were talking about?

No. I was talking about turning on Hidden Geometry (View menu) so you can see the softened edges like I showed in my screen shot. That makes it easier to see where to add edges to skin over the holes.

Hmm- pretty sure I screwed all this up with the slider?

OR is this a good starting place to make those repairs you mentioned?


Clover 8 24 21.skp (3.2 MB)

It doesn’t look like it’s any more screwed up than it was before. After you’ve fixed the holes, turn off the Hidden Geometry again and soften the new edges you’ve added.

Can you be more specific as to how to locate and fix these holes?
Here is the area I suspect:
I tried simply add lines to create planes, but they don’t seem to heal…
Also, when I zoom in, a gray shadow begins to block my view…

image

image

Zoom in closer and then use the Line tool to connect the corners. The Dave Method would be useful here, too. Erase the unneeded edges and then soften the remaining ones.
fix

That seemed to work thanks!
Can you tell me how you were able to zoom as tight as you did?

image

NVM - Parallel projection seemed to make it zoom-able.
Thanks!

I made a component and then used the Dave Method as I suggested you do.

Aha. So your component was scaled up, when you made those repairs?

Yes. A copy of it was.

Sketch Up Pro