SketchUp Won't Save File aAfter Import

I have been having a problem saving files after I import another SketchUp model into my model. This only started in the last week with 2 different models. In both instances I have my site modeled in a separate file from the building model. Once I import my building model into my site model, my site model will not save. I get a “cannot save file” error (or something to that effect). In one instance it would give me an error message when SU would try to auto-save as well. If I copy and past the building model into the site model it works. I can even refresh the grouped building model and it updates the changes saves just fine. Am I doing something wrong or is this a bug? I am using SketchUp Pro 2019 on a Windows 10 computer. -Thanks

are both geolocated the same?

john

I don’t have either one geolocated. I created the train from an imported .dwg file provided by a surveyor and I used TopoShaper to create the mesh. Both site models were derived from drawings from two different surveyors as well.

How big are the individual SKP files? Have you purged both files to get rid of unused stuff?

One of the files is 7,314 kb and the other is 6,236 kb. I have tried to purge and fix errors in both site models and in the building models.

How about uploading the files to drop box and sharing the link so we can have a look?

@DaveR,
Here is a dropbox link to the files: https://www.dropbox.com/sh/gn90mukcfwa294p/AACKa2AXN_rWuPVRXQS6VvAAa?dl=0
If you try to import the building model 1 into site model 1 it should give you the error message. When I tried to re-create the scenario with site model 2 and building model 2 in the dropbox folder it worked fine just now, but earlier it was giving me an error. Please keep in mind that these are my working concept models so they are not cleaned up yet. Let me know if you get the error too.

Hmmm… I inserted the House 1 model into the Site 1 model. Didn’t know where it was supposed to go exactly so I stuffed it in at the origin.

It saves just fine, too.
House 1 Site Model with house.zip (1.8 MB)

I wonder if this is somehow related to your graphics card or an issue with Condoc Tools which it appears you are using.

The building was being inserted into the hillside and nestled into the mesh. I’m not sure why that would change your result at all. Yes, I am using ConDoc tools. I will play around with it tomorrow and see if I can provide any more info.