Sketchup with Vray plug-in rendering is only using CPU?!

This post may be of interest.

Try to also set Vray to use your Nvidia GPU and not the integrated Intel graphics. If a choice does not appear by right-clicking the Vray icon, then open the Nvidia Control Panel, and make the setting there.

Here is another post with a screenshot of the Nvidia Control Panel: