Sketchup viewer crashes after signing in


#1

Hello,
my sketchup viewer crashes after signing in. I can not start it again and have to install it again.


#2

Hi chris_gruen,

I have a few questions to help us troubleshoot further;

  • Are you able to sign in on that first run?
  • Do you see this issue if you’re signed in vs if you are NOT signed in?
  • What is the device you’ve installed on?
  • What version of Android do you have installed?

I look forward to your response.


#3

Hi jody,
no, I’m not able to sign in. If i’m not signed everything works fine. If i try to sign in it crashes and it won’t start again.
It’s installed intern. Android version is 4.1.2
thx


#4

We crashed version 1.0.3 on Android 4.4.2. Bug filed. OAuth unauthorizing does not fix. We’ve heard re-installing the application will.


#5

Jody mentioned this may not be clear to all: when you authorize and sign into 3dwarehouse, extension warehouse or SketchUp, we’re using Google OAuth to sign in. If you ever feel like you want to log out of EVERY property we have on every device you signed in on, you can go to https://security.google.com/settings/security/permissions and revoke access to any applications you’ve given access. You should be forced to sign in again in any application you have running.

And in this case, revoking access did not fix the problem. Reinstalling the application did.


#6

I can sign in with my account aon Sketchup 2014 on my PC. Thats no problem. When i try to sign in on my tablet the following message comes:'
Authentication error! Something went wrong during the authentication process. Please try signing in again.'
When i go to the sign in button now, there comes the button 'Sketchup was finished’
Then i put the ok button and i can never start sketchup again


#7

Sowent to the link, logged out the sketchup permission, uninstalled sketchup, installed it again, started it(everything worked fine) than i tried to sign in. It worked, icoud see the warehouse window for 5 seconds and than sketchup crashed again and i can’t start it again


#8

We posted a fix earlier today. Please update and let us know if it worked.


#9

Yes, I’ve seen it yesterday. It works!!! Thank you very much!!!


#10

Hello,
My sketchup viewer work well before on my android (jelly bean 4.3) but suddenly it crashed, I tried to open the apps and it was loading, but after approx. 5 seconds it shut down by itself and appear “Unfortunately, sketchup stopped working”. Can anybody please help for this issue?

Thanks…


#11

I have just forced Sketchup from google. Uninstalled Sketchup mobile viewer then restarted my Galaxy tab (SM-P600) running Android 4.3
Re-installed the app and logged back in and it still laughs at me.

Where is the fix and how do I get it?


#12

Hi all,

New update released today that should resolve all known issues.

Background/clarification:
There were 2 different bugs.

One of the bugs was related to Sign In. V1.0.7 (released last week) included a fix for that issue.
Another, unrelated bug surfaced soon after. That one was related to 3D Warehouse. We’ve just released a new version V1.0.8 that includes a fix for that issue.

Sorry for the trouble. And much thanks for all the reports. Very useful in helping us address and resolve issues quickly.

Please let us know if you continue to have problems after updating to V1.0.8.