Sketchup V-ray component materials not loading properly

Hey everyone, first time posting here, pretty desperate! I’m pretty new to using v-ray with sketchup.
My problem is this, I’ve got a pretty heavy scene so to make things easier to work, we’ve seperated it into components for say landscape, architecture, structure etc. I then work on the smaller files individually and then reload the components.
Here’s the problem : some vray materials are applied in more than one component, and the ‘duplicate’ materials seem to lose their properties in the main file.
I’ve attached a few screenshots as examples.

If anyone has any ideas on how to fix this problem, I’d be very grateful!
Thanks :slight_smile:


This is the regular version of that material (couldnt put more than one per post)

Not entirely sure what you are describing in regards to ‘losing their properties’ without seeing the scene and being able to examine the materials setup but depending on how many duplicates of each material you have - just right click on the ‘master’ material and select ‘Use as replacement’ and select the duplicates and right click replace in scene’.

If you can share the file, I’ll gladly take a quick look.

The replacement method does sort of work, but it’s a huge file and that action takes ages to process it seems.
Unfortunately this project is confidential and I can’t share the file. Here’s two more screenshots of the same ‘material’ one that works and the other one that becomes all black.

This is what that should look like

What is your Vray version?

The latest v-ray next, was installed a month ago I think it’s 4.2

Ok, just as an aside, have you Purged Unused Assets? (The broom icon)

Just because they are in the list - it may just be a reference that Vray brings in with the Component.
Its takes a little while for Vray to go through the Tree but should should see this duplicates gradually disappear in front of your eyes.
I often see multiples like that without attributes, and I just Purge to clean up the material list.
If you use SketchUps own Purge Unused in the Mode Info dialogue - it doesn’t respect Vray Materials, so leaves a load of ‘cruft’

Do you know how to use the ‘Replace all in Scene’ function? While not a solution to your original problem, you could quickly copy and paste the correct settings from one material to the others. I’ll test the scenario you’ve described with reloading components and see if I can replicate the original issue.

Yes I’ve tried using that, the issue is that it’s so heavy it spins forever and never seems to actually succeed, I let it run for 30 minutes and it was still spinning :S

are you replying to me or Eric…
I opened a scene that had exactly the same scenario as you - I was combining components into a master model.
Had multiple instances of the same material without attributes but one that had the correct attributes - just as you show above.
Used Purge Unused Assets - took a while but they all went and model is all good.
It can take an absolute age on a complex scene and in usual Sketchup way there is no progress indicator but a spinning beachball (for me) but the processor thread is maxed out and eventually you can see the bad assets just drop out of the Asset Editor

1 Like

Was answering Eric, but the same was happening with the purge. I’ll give it another try and let it run its course I guess! Thanks for the help and for testing it in your scene, I’ll let you know if this solves it. I’m also wonder if re-naming the materials in the original scenes might solve this as well? Will give it a try also if this doesn’t work. Would be nice to have a workaround to not have to go through this every time.