Sketchup to SheetCam impasse!

Hello SketchUp community!

Trace here, long time digital craftsman but short time SketchUp forums user. I got an ArcLight CNC plasma system about 8 months ago and have enjoyed learning the ropes of the various programs. I’ve cut lots of different DXF files from SketchUp cooked through SheetCam without much problem, but have come to an impasse today. I’m making a model in SketchUp of seven different moon phases on a fun landscape. When I put the test file into SheetCam, about 80% of the arcs in the drawing are missing. All the straight lines seem to have swung programs without a problem but the arcs took heavy casualties. Seems to be more prevalent with circles (and arcs) that I’ve scaled to be elliptical moon craters in SketchUp. What’s going on here? Fixes I’ve tried:

-Changing the SketchUp view to parallel projection
-Changing the arc fitting tolerences in the SheetCam drawing import
-Merging the circles with the model in SketchUp
-Converting the DXF export to an SVG before importing into SheetCam
-Importing a DWG into SheetCam
-Making sure that I’m perfectly top-down in SketchUp before exporting
-Importing both the DXF and SVG into QCAD, separately. They look the exact same, so I’m thinking it might be on the SketchUp export vs the SheetCam import.

Thoughts?

Any help would be greatly appreciated! I spent about 7 hours making this file and am super stoked to get it engraved and cut! Thanks in advance.

-Trace



If you share your file someone may be able to spot the issue. I’m guess heavy segmentation may be involved.

I’ll give that a shot. Sorry for the response delay. I was out of town. How’s this look? I have the SKP and the DXF here, though the DXF is just an excerpt of one of the panels (6th one from the left).

Jawbreaker6.dxf (116.3 KB)
Jawbreaker.skp (1.7 MB)

Try copy paste the pattern into a fresh model space, lay it down flat, set camera to Standard View Top and Parallel Projection, and Zoom Extents. Then export the .dxf.
If I do that I get this in lightburn.

If it was me I would probably go through it with Fredo’s Curvizard to smooth the edges first so things are less jagged when you cut it.

Maybe it has to do with the difference between 2d DXF and 3d DXF export?
Common sense would dictate to export as 2d DXF for a 2d CNC operation but that doesn’t bring over the true arc and circle information. Export as 3d DXF does do that.

Excellent! Thanks. I’ll give these a shot. I really appreciate the help.

Tried a bunch of tricks today, to include the ones recommended. Nothing seemed to work, then I saw “Weld Edges” as an option in one of the drop down menus and that did the trick! Still imported with a bug or two, but way better than getting ~40% of my file. I’ll be welding edges and using some of the other suggestions in future drawings. Thanks again for the help!

-Trace

View the dxf file. Is this what you need? I used the ABF Vietnamese plugin for this https://www.getabf.net/ . It is free and has a very good dxf export for CNC cutting. You will get arcs and layers if your geometry is layered.
First, I created a group from each of your images and named it ABF_ (this is important. this prefix must be there). I then created 18mm thick panels (groups) to the dimensions of each ABF_ group created (this is the “material”. The thickness doesn’t matter. Use your own). I then nested the appropriate ABF_ group in the middle of each respective panel. Made a layout and exported it to dxf (plugin).
JAWBREAKER.dxf (1.2 МБ)


Got it all sorted but that’s useful information. Thank you!