SketchUp suddenly decides nothing can be edited

Typical scenario: Editing the textures of the floor tile edging. New object each time there is a corner, so plenty of them.

Going along - select object, explode, select face, paint, texture, position, make group, and then on to the next one.

Suddenly, right-click has everything greyed out. No editing allowed. selection lines still blue, so not locked.

Exiting SketchUp and starting again works.

SU 2017 Make

That’s not nice.

Exploding seems to take a lot of memory with SU. I hardly find the need. Do you have to explode groups often?

I intend rendering in KT. I have created my own material, complete with maps. Now I have to redo all the floors, all the edges of the floors, and all the baseboards.

And the floor edgings have been shaped around the doorframes, so a lot of editing to be done.

I have 20GB of RAM.

Why are you exploding the groups then regrouping? Why don’t you just edit the groups?

3 Likes

@macnab, this would be a nice time to share the model for others to see and get you specific answer(s).
Maybe there’s even a better way as to workflow to help you out.

It is 75MB total. But I will save just the floor bit and you can see what I mean.

Before you do, purge unused first to see if the file size drops.

This is just the floor tiles and edging tiles. Material created myself from a photo of my actual tiles. All the top surfaces need to be painted and aligned.
Walls have baseboards which have to match the edging alignment.
Workflow:
Click on group.
Right-click -> Explode.
Click on top face to select.
B for Paint Bucket.
Click on face to paint it.
Right-click -> Texture -> Position.
Position the texture.
Click outside to accept position.
Space-bar to get selection tool.
Triple-click to select whole object.
Right-click -> Make group.

And on to the next one.

Then out of the blue context menu is greyed out.

Floor only.skp (5.0 MB)

First read this, there are very important advices for a beginner!

  1. Be sure that all raw geometry - edges and faces - are always associated with “Layer 0”.
  2. Keep “Layer 0” the active layer at all times (which goes a long way to ensuring point 1).
  3. When you have identified a set of geometry that represents some more-or-less independent “thing,” create a Group or Component to hold the thing’s raw geometry. This could be a wall, or a set of adjacent walls. Groups and components can be nested, so you can have a North Wall object, a South Wall object, etc. and then collect the various walls into a First Floor object.
  4. If you want to control visibility of objects via SketchUp’s layer feature, associate those groups or components with various layers. Do NOT associate any of their actual edges and faces with a custom layer; only associate the overall group or component with the custom layer.

When you select a group, right-click on it and choose Edit Group, not Explode.

See the button for upload.
Thanks for the advice. I actually do all my organising in Outliner, with properly named groups and everything - makes finding things to edit easier.

I will try Edit Group instead of Explode and see if that helps with the problem.

You’ll benefit from watching these…

SketchUp Training Series: Components & Groups


SketchUp Skill Builder: Hide Rest of Model


SketchUp Training Series: Layers

1 Like

Going back to your original problem, are you using any Fredo extensions?
If so try updating the Libfredo to the latest version.
It is possible that a small change Fredo made recently may be causing the faulty context bug.
So it would be good to know if you are using Fredo and if so does the update appear to fix your issue.

I will check LibFredo. It seems as though since I started using Edit Group instead of Explode that the problem has gone away. The only thing that got disabled was Rename, which I was using a lot.