Sketchup SDK questions?

So I wanted to refresh my plug-in for 2017, but am not able to find where I can download the latest SDK. Can someone please give me a link?

https://extensions.sketchup.com/en/developer_center/sketchup_sdk

If you are logged in (and are a registered developer) then you should see the download buttons at the bottom of the page.

I am a registered developer and logged in, and all I see is a button for the application to be a developer. Very frustrating.

if I click dan’s link it takes me to a page with a ‘sign in’ button at the top left…

when I sign in with my ‘Trimble Identity’ I have the option to download the two SDK’s…

I use to log in with my Google account, but recall that going pear shaped a while back…

BTW: the last time I built the xml sample with Xcode it ran fine from my ~/Library/…/…/Plugins path…

john

Weird. Maybe my Trimble ID is not a developer’s ID? I certainly downloaded the last several years (over the years), and was in the beta program with that Trimble ID, so I’m not sure what’s up. Hopefully Tuesday someone there will answer my email and I’ll get developer’s credentials again.

Try using the ID / password that you use to log into the developer center and submit rbzs for encrypting.

The only developer work I’ve ever done is for our in-house Objective-C++ plug-in for the Mac. I’ve never submitted it anywhere.

Well, there is no way I could divine what account you used to sign up as a developer.

Do you receive developer email notices to any particular account ?
(There was one sent just this past May 19, entitled
"C++ API is no more! What do you need to make the switch?",
which talked about the planned deprecation of the C++ API, and asked developers using the C/C++ APIs to take a poll.)

Yes, I did get that email.

And no, I don’t expect you to know :slight_smile: , just mentioning it in case there’s a Trimble person reading this that can check.

I’m wondering if this feature (making it possible to load plugins via ~/Application Support/SketchUp/…) is still on your to do list?

I just checked in 2019 and it still doesn’t work. I’d love to know if it’s supposed to work and I’m just doing it wrong?

It’s pretty icky to have to copy a plug-in into the app bundle, and it looks like this was a thread from 5 years ago. Would be great to see it get bumped up in priority.

Note if it ends up still being a “to do”, please file a public issue so it can be tracked and discussed in the SketchUp API tracker GitHub repo.

v18 I wrapped the XML exporter in a zip, inside a .rbz…

the loader script for the .rbz called Sketchup.install_from_archive(my_zip) and that worked…

john

1 Like

But Paul said in NOV of 2014 …

Has this officially changed and with what version did it change ?

I just shoe horned it into existing extensions on v16…v19

v17…19 all worked but 17 + 18 both popped the has access to your files dialog during the load…

that may be how deep I buried them as they where in extension files and v19 in a menu file…

16 loads it into User/plugin and bug splats if you open Export 3d …

I guess it was added to v17, but it may be my test at fault there…

john

I went completely through the C SDK "version.txt" file and there is no mention of any changes in regard to the Mac .plugin (folder/bundle?) importers / exporters.


The "ReadMe.md" file in the root of the skp_to_xml sample project still says …

#### Mac:

1. Go into xcode project after building and locate the Products folder
    in the project navigator.
2. Right-click the plugin and click Show in Finder.
3. Copy/paste the plugin into
    /Applications/SketchUp 2019/SketchUp.app/Contents/PlugIns
4. Run SketchUp 2019 and create a model.
5. Go to File -> Export - 3D Model.
6. Choose "XML Exporter (*.xml)" as your Save type.
7. Give the xml a filename and click Export.

Lets continue in the thread we already had going about this:

Well since I posted here about the SDK import.export sample’s readme files, would you agree their ReadMe(s) need updating for installs on newer OSX versions ? (Ie, ref the path in no. 3 above.)

1 Like

The SDK documentation generally needs an overhaul. :confused:

1 Like

Well all the “needs” will keep you employed. :wink:

REF: API Issue filed: https://github.com/SketchUp/api-issue-tracker/issues/316

Yea… ain’t no lack in work to be done…