Sketchup repositioning camera when I click centre button to orbit

Hi folks, this behaviour just started. I guess I must have accidentally hit a keyboard shortcut to change something, but I don’t know what.

Whenever I click and hold my centre button ready to orbit, Sketchup repositions the camera so that the centre of the screen is wherever my mouse happens to be at the point I clicked.

Can someone advise how I switch this off? Thanks

Is it possible you are getting a double click of the CMB? That would move the point where the cursor is to the center of the screen. Maybe you need to clean the mouse or maybe it’s worn out?

There isn’t a setting in SketchUp to switch this off.

Thanks Dave. The mouse wasn’t double-clicking, but Windows was for some reason registering a double click. A quick restart and all is well. :slight_smile:

1 Like