SketchUp Pro model has disappeared, but file still exists and contains data


#1

Hi helpful SketchUp people

I’m relatively new to SketchUp, so I may be missing some obvious stuff.

I’ve been working on some section drawings (not 3D stuff) and they have suddenly disappeared, despite zooming to the full extents of the model.

Both the skp and skb files are still there, and both contain data (at least, they have volume so must contain something), but everything has disappeared from view

Help… :sob:

RobHilstead - Details_06.12.18.skp (2.6 MB)


#2

Switch all layers visible and unhide everything.

What does “Window > Model Info > Statistics > Entire Model" say?


#3

You have fallen victim to the known singular text bug, which causes leader texts to fly off to infinity. This happens when you annotate a basically 2D model using leader text and then edit the faces in certain ways. Until it is fixed, the only workarounds are a) to not attach leader texts to 2D entities until you are sure you are finished editing, or b) attach such annotation in Layout, not SketchUp (an option for you as you have SketchUp Pro, but not for people who have only Make).

Here’s a repaired version of your model

Hilstead - Details_06.12.18.skp (2.6 MB)


#4

Thanks - you are a star!

For future reference, how do I “unhide” everything?


#5

As a start, make sure all Layers are visible and then enable View->Hidden Geometry to see whether you actually have anything hidden (I didn’t find anything hidden in your model). After that it’s a bit tedious as the Edit->Unhide All menu item works only within the currently open edit context (model, group, or component) so you have to work each one to unhide everything. This is one of the reasons most experts advise to use the hidden flag on entities only as a temporary measure (e.g. to be able to view something they obscure so you can edit it), and to make them visible again as soon as the task is completed. Confusion is otherwise almost inevitable! I think there are plugins that will address this limitation of the UI, but I can’t remember them offhand because I don’t use them (I follow my own advice and use hide only temporarily).

It is far superior to use Layers to control visibility - but with one essential caveat: unlike layers in many 2D applications, SketchUp’s Layers do not isolate geometry from interacting (sticking together and intersecting). Instead groups and components do the isolation. So you should only associate Layers with groups, components, and non-geometry objects such as dimensions, leader text, and images, always leaving all edges and faces associated with Layer0. To avoid errors, you should always leave Layer0 as the “active” layer. Draw all your edges and faces using Layer0, make groups or components from them, and then associate a Layer with the group or component instance. It is not necessary and not even desirable to associate the entities inside a group or component with the same layer as its container. In fact, unless done carefully this can cause very confusing issues with strange visibility behavior as you toggle Layers from visible to non visible.

You have done a good job using groups and components - there are relatively few edges and faces “loose” in the model - but you have nearly all the edges and faces in the model using other than Layer0 and have another Layer selected as Active. You can fix this manually by opening each group for edit, select all, and choose Layer0 in the model info window. There are also extensions such as TIG’s Layer Watcher that will automate this task and also block you from accidentally misusing layers in the future.