Sketchup pro 2023 is slow when hovering around with 3Dconexxion space mouse

Hi there, I just got my new MacBook Pro 2023 (14-inch MacBook Pro - Spacezwart - Apple (NL)) and switching from my MacBook Air I thought everything would run smooth and easy.

When I opened my sketchup with my loaded IFC file in it, it just isn’t as smooth as I thought it would be.

Now my question: are the specs of my MacBook still to low, or has it to do with something else?

When im hovering around with my 3Dconexxion space mouse its just laggy and slow, when I hide my IFC house it all runs smooth and easy.
Link here: https://youtu.be/wyT_do_NkOg

I tried it with other IFC files aswell, larger and smaller files, same problem unfortunately.

The way I import these IFC files is: I upload them to Trimble and download them back as .TRB, that way Sketchup imports it with all the components showing.

Is it a Sketchup problem or a Macbook problem?

Thanks in advance!

I think it could be a model problem, sketchup behaves that way when the model has a lot of geometry and large textures, having activated the profiles on the styles tray also affects the performance. Can you share on of the files you’re having issues with?

Btw. you can also import ifc files with a plugin called ifc manager, it’s faster than uploading it to Trimble export as trb and then import from sketchup. If you work with files made on Revit you should check the studio version, it has a Revit importer that the pro version doesn’t have besides other features.

Thanks for the response, here’s a download link to the file: https://wetransfer.com/downloads/6599ba34316263519da100ec77089d9920240215140024/56994a210d54e9a6c1230eafc94ee1b920240215140034/01f4ad?trk=TRN_TDL_01&utm_campaign=TRN_TDL_01&utm_medium=email&utm_source=sendgrid

I’ve tried the IFC manager but the IFC model doesn’t show all components that way…

hi,

Capture d’écran 2024-02-15 à 15.11.27

so first, this is the backup. not the main file. you can see the ~at the end. :slight_smile:
(telling you just in case you didn’t know)

it doesn’t lag or anything on my end. tag usage is clean, materials too, but you need to purge components :

your file is filled with non used components, about 50% of the weight.
Capture d’écran 2024-02-15 à 15.16.44

there have been some issues with 3d connexion mouse when SU23 was released, is the slow hovering happening when you’re using a regular mouse too ?

thanks for telling me, I didn’t know indeed.

View - Component edit - hide similar components worked already yeah.
Is there another option to purge the non used components?

The lag is a lot less with my normal mouse, but not as smooth as I want.

Hide similar components does not remove anything from the model, it just reduces visual clutter when you are editing a component. You can purge unused components, tags, materials, etc from the model info statistics panel or using an extension (I refer TIG’s from sketchUcation because it gives a better report when finished).

with native tools, you can purge in 2 places :

in the component panel, first click on the little house (to see the components in your model), then the small black arrow over a blue/white rectangle on the right (where the menu appears on my image). here you can choose “purge” at the bottom. here I can’t purge since I already did it.

the other place will purge everything, it’s in model’s info / statistics / purge, at the bottom. it’ll purge materials, tags, components…

Or through extensions like Steven says. I use one from the extension warehouse, CG impact report, that tells me which groups and components are big, small, used or not… and it allows me to purge aswell.


edit : pretty much every objects in your model are individual components, probably because of the IFC. it’s fine, but you’ll have to think about a purge from time to time, since everything you delete in your model won’t actually be deleted until you purge.

Thanks man, this helped me a lot already!

It’s already a lot smoother than it was before.
Do you guys think my Macbook is specced enough, or do you recon i need the M3 max with 32GB?

Unless you regularly build enormous models or run other apps such as renderers simultaneously, the M3 Pro should be quite a nice performer.

well, I’ll asume your profile is correct, you have a macbookpro from 2023 so probably a M2 something or a basic M3? it’s more than fine.

I opened and purged your file on a mac mini M1 from 2021 with 16gb ram. so an inferior machine :wink:

the sluggishness might come from the IFC, it got converted into sketchup system (groups, components) as best at it could, but still you’ll have weird things.

take this panel.
Capture d’écran 2024-02-15 à 17.31.05
it’s a single component. 6036#1

however, when I enter it, it contains another component. this one isn’t alone, it has 11 copies 355#1


I’ve marked them red in this video.
11 identical panels should be 1 component with 11 copies. here you have a total of 12 components, 11 unique containing the 11 copies.

that redundancy can create sluggishness. it’s inherent to importing from other softwares and formats, like IFC