Sketchup Pro 2020 Freezes after Welcome Screen

Sketchup Pro 2020 Freezes after Welcome Screen.

I have a working version of Sketchup Pro 2019 – no problems whatsoever. Runs smoothly.

Upgraded to Sketchup Pro 2020 and have had multiple problems. The application ran well a couple of times and then stopped working after a required System BIOS update. I am not going to uninstall a required System BIOS Update.

The latest status of Sketchup Pro 2020 is that the application will freeze when starting. I run the application and I get to the Welcome Screen no problems. Then when I either create a new file using any template (I have tried them all), or attempt to open an existing Sketchup File, I can see the Application Window, but with non of the window elements accessible (i.e. greyed window icons, so I can’t even maximise, minimise, or close the window).

When I click anywhere on the screen of the Sketchup Pro 2020 application, a Windows Alert sound is produced. And the application does not react. When I rightclick on the application icon on the task barto end the application I have no response either.

I have fully uninstalled and installed the application (twice), downloaded a fresh installer, checked that I have all the latest software and bios updates in my system.

System Details:
• Dell Precision 5530 2 in 1
• CPU type Intel Core i7-8706G CPU @ 3.10GHz
• Windows 10 Pro (64 bit) with the latest BIOS and updates.
• System Memory 16 GB
Graphic Cards:
• GPU AMD Radeon Pro WX Vega M GL Graphics
• GPU Intel Graphics 630

I have changed the preferred graphic card settings on the application, for it to run on the Radeon or the Intel. None of the options will work. The software was running with the Radeon as a default.

When changing the Graphics Card Settings to the Intel Graphics Card received this message:

The following warnings were found when launching SketchUp:

  • SketchUp has detected your computer system has multiple graphics cards and is defaulting to an integrated Intel graphics card. SketchUp will perform better if you change your system to default to the AMD/NVIDIA card.

See this Help Center article for more information.

I have read this article carefully, and gone back and checked that all the Graphic Acceleration settings are there, which they are.

Changed back to use the AMD Radeon after a system restart, ensuring all the graphic acceleration requirements were met, and the warning message went away, but the application still freezes after I leave the Sketchup welcome screen.

Each time, after a reinstall, restart and making sure that the Sketchup Pro 2020 Application is using the Radeon Pro Card, both on the Radeon Pro Settings app and the Windows Settings App, I have the same result:

I can see the screen of Sketchup Pro 2020 (Woman with sunglasses and handbag), but the window is not active, as when I click anywhere on the window I get a Windows alert sound yet again.

When I call the Windows Task Manager to terminate the application, the Sketchup Application is not on the list. Instead, there is a “Welcome to Sketchup” application, suggesting that the welcome screen is still active, instead of the proper application.

I have tried doing this either creating a new file using the templates or by opening an existing Sketchup Drawing.

I have tried to deactivate the welcome screen, as you could do in older versions of Sketchup, but I cannot find this option.

Nothing will work.

I feel like I’m running a Beta piece of untested software here. Very frustrating. Sketchup Pro 2019 works perfectly fine, and I cannot afford to uninstall this as I need to have a working application.

I’ve read the forums and I’ve not found this specific problem for Sketchup Pro 2020 and wonder if anyone else has this issue, and what I need to do to correct it, or whether a new version of Sketchup 2020 is coming, as this is completely unworkable.

Thanks in advance for your help.

After a BIOS update, it is also important that you make sure that your device drivers are up to date. Especially, you should go to either Dell or AMD and update the driver for your AMD graphics card. If Dell has other driver updates for you, better install them too.

Thanks for your response. Yes, I know that it is important that all drivers are up to date.

I can confirm that all drivers are up to date, I have double, triple checked, particularly the drivers for the AMD Radeon GPU. I have run the Dell Drivers and Downloads SupportAssist Utility several times, and all drivers are up to date. I have also manually checked that the AMD Radeon Drivers are up to date, and they are the latest ones (Version 24.20.11026.2001, A01 Last Updated 02 Aug 2019).

Software that runs perfectly includes all Microsoft Office, Adobe Suite (Photoshop, Illustrator, Premiere, InDesign, etc.), Sketchup Pro 2019 with V-Ray (Including high performance renders), AutoCad… etc. No issues whatsoever with any of these programs.

The only software currently not working, in spite of the multiple times I have performed a clean reinstall, is Sketchup Pro 2020.

I am not sure it was the BIOS Update that caused Sketchup Pro 2020 to stop working but I mentioned it.

I am still at a loss as to why this is happening.

Happy to provide further details, including a detailed report on all the current drivers and system if it helps solve this problem.

I look forward to a prompt resolution to this issue.

I haven’t read all you wrote, but it sounds like the welcome screen is opening off screen, once it starts so the focus is on the welcome screen, press alt and spacebar together, then tap m, then tap any arrow key and without clicking, move the mouse around until the welcome window appears.

Hi Box, thanks for your reply. Sadly, the Welcome Screen disappears altogether, and I can see the actual Sketchup App window. There is no welcome screen open.

I would be able to see the Welcome Screen too by pressing Alt+Tab, and switching through the open windows, but this is not the case: There is only the Sketchup App and Firefox open.

Sometimes the Task Manager shows a Welcome to Sketchup, sometimes it shows Sketchup Application.

Thanks for your help anyway guys.

The AMD driver supplied by Dell sounds old (more than a year). I have often noticed that laptop vendors do not continue their driver support very long after the model is released. You could go to the AMD website to look if they offer a newer version. Of course the reason for your freeze might lie elsewhere. Do you run many extensions?
Display drivers are also often made dysfunctional by Windows updates, the cause is not necessarily your BIOS update.

Hi Anssi. Thanks for your reply.

Your shrewd suggestion of removing all extensions worked! I had several, amongst them the Sefaira, Freddo and 1001 Bit Tools.

I will very carefully vet them and test them, and only install what I truly need. I guess some extensions will simply not work well with the new Sketchup Pro 2020, so I have to be careful.

Again, thanks for contributing to the community with your insight and problem-solving ideas.

I suspect the popup from fredo was hanging somewhere, as @Box suggested.

Hi Mike!
Possibly! However, it was not visible. It must have been within the Sketchup Window. There was no ESC Key or return Key that would eliminate the problem though. I just removed everything. Will start bit by bit.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.