Sketchup Pro 2020 and Layout 2020 - Dash Lines

Hi

Second post for the day :wink:

This one is a Query on the display of Dashed Lines in Sketchup Pro and Layout.

I have attached 2 images; one screen shot from Sketchup showing how Dashed Lines are displayed, and one from Layout showing an Overlay Viewport created and then the Style changed to Dashed Lines, using the new feature where Styles and Layers for Viewports can be selected/modified.

The element is question is a Circular HVAC Duct. As can be seen, in Sketchup it displays correctly. Profiles are turned on in the Saved Style Setting, allowing the ‘edges’ of circular elements to be displayed in dashed lines.

In Layout, when I create the Overlay Viewport and then select the appropriate Layers I want t display, and change the Style to my Saved Dashed Lines Style, it seems to also show every edge which makes up the Circular Duct.

This is not a huge problem, but curious as to why it does this. I would prefer it to display like it does in Sketchup as it is tidier.

Kind regards

Mike

Mike, that’s a curious thing. I just set up a test with a plan view of a cylinder and did a similar thing in LO. Selecting a style with dashes gives me the desired appearance in LO.
Orbited the view to show it’s a cylinder.

Original scene top, Hidden line with dashes bottom.
Screenshot - 2_15_2020 , 6_43_37 AM

Would you send me your LO file so I can see?

HI @DaveR

No Problem.

Hopefully this Dropbox Link works.

Kind regards

Mike

Hi Mike,

Looks like it works. The file is downloading. Do you care if the file is public? If you don’t want it public you could remove the link.

Good Point.

I’ll remove the link when you have it.

Mike

I’ve got it open. Waiting for the SketchUp model to open.

Thank you.

It’s stumped me.

I did wonder if it has anything to do with the fact that I used Profile Builder to create the Component.

Mike

I don’t think so. I rebuilt it with a circle and Follow Me. No difference.

Solved. Thank you to @DaveR for the brilliant Help.

The problem was caused because I had switched Off ‘Untagged’ in the Layout Viewport, using the new Tags Pull Down Option, for Viewports.

This meant that all the geometry within the Groups/Components was effectively off.

Switched ‘Untagged’ back on and the problem is gone.

Mike

2 Likes

Interesting. New features means new ways to mess it up.

2 Likes

Previously it hadn’t occurred to me to even try changing Untagged to invisible in the SketchUp Model panel so I didn’t know it was possible. I figured it would be like trying to turn off the visibility of Untagged in SketchUp.

Intuitively, it seems that if all edges and faces were untagged as they should be, turning off visibility for Untagged in LO should make everything disappear. That would mess with some folks. :smiley:

1 Like

Remembering what I did, I did a Shift Click to select ALL the Layers to Turn them off, and then selected the HVAC Layer to Turn it back on, rather than click through them one by one.

Doing this, I included Untagged, which I shouldn’t have done, meaning that I turned it off.

Still, I’ll know for next time. Another lesson learnt.

Mike

1 Like

Ah, yes. That makes sense. Maybe a small change in the process. Highlight the first tag (not Untagged) and then Shift click on the last one…

That’s what I’ll be doing from now.

I do love this new feature though. Seems to give a bit more freedom when setting up Scenes in Sketchup, as they can be tweaked/adapted in Layout to suit.

I played around with the Fog setting in Layout too, to see if it would do the equivalent of adding an opacity layer in Layout, to ‘knock’ the viewport back, visually, before stacking another viewport on top. It didn’t seem to do much, and I could not see a setting for depth/distance of Fog. I assume then, that the Fog must be added in Sketchup first, and the Layout Fog Option just allows it to be turned on or off.

Mike

1 Like

I’d have to look at the fog setting. I don’t have a lot of use for it in most of my models.