Sketchup pro 2019 - cannot launch my desktop app for first time - macos catalina

I JUST PURCHASED SKETCHUP PRO 2019 SUBSCRIPTION.

TRYING TO LAUNCH DESKTOP APP FOR FIRST TIME…

IT TELLS ME TO CLICK “SIGN IN” TO ACCESS MY SUBSCRIPTION…

IT TAKES ME TO LOGIN.SKETCHUP.COM AND SAYS IT DOESN’T KNOW WHERE I WANT TO GO TO… (see screenshot)

DOES NOT REDIRECT!!


PLEASE HELP!!!

Going to login.sketchup.com will show the page you’re seeing, but SketchUp is supposed to be sending you to https://identity.trimble.com/. If I set Firefox as the default Mac browser, I still get taken to https://identity.trimble.com/ and not login.sketchup.com.

I don’t know why the sign in would open the wrong URL. I’m asking around to see if anyone has ideas.

Under the hood you should be getting sent to https://accounts.sketchup.com/en/user/login (assuming you are using the english build). If you click that link does that also fail for you?

Thanks colin and joe_b. Eventually it took me to “Sign in to all things SketchUp” via chrome, but I had to wait almost an hour after several retries, and after Trimble finally sent me a confirmation email to complete my profile and sign into to my account. Bit of a slow buggy start, but I’m in now :slight_smile:

Thanks for the report. It’s an interesting problem that you’re able to buy SketchUp with a new Trimble ID, download and install it, all before getting the confirmation email for your Trimble ID. I’ll check if that is a test that we do.

We auto assign almost everyone who buys a subscription. We need an email address, front and last name.
When we do this, the email address is ‘reserved’ to be a Trimble ID if it does not exist.

eg. When bought outside the USA via partner or reseller