SketchUp Pro 2018. Error message that google is not defined in 2018

Command, “Generate Report” does not work in SketchUp Pro 2018. Error message that google is not defined in 2018. Whassup?

Can you show a screen shot of the exact error message?

It might be related to SketchUp’s Current Minus Two policy and changes related to web UI services.

The exact message is:

ERROR: Uncaught ReferenceError: google is not defined @ /2018_generatereport.html?hl=en[14]

Closing the dialog seems to leave you with a working generate report.

Thanks, Colin. That is the error message wording. I tried with a working model, and just a blank SU screen. In both cases, I got the template (I wanted to create a new template). That seemed to be ok, the report applet started, but all I got was the same error message and no report. I first started with SU when I bought a copy from @Last Software, way back when. I used to generate bills of materials with it with no problem. This has me confused as to exactly what I need to do.

@colin is the Generate Report feature still supported in SketchUp 2018 or, since it requires a web connection, does it fall under the Current Minus Two policy?

I don’t know what its current state is, but it may be suffering the same issues as 3DW, EW, and Add Location are. Which is that those sites are using techniques that may not work well in the Chromium that is built into older versions of SketchUp.

@Bryceosaurus may know more about whether the error is something that can be fixed.

Since the error message references Java script, do you think that that may have something to do with it (the problem)? Just a hopeful guess.