Sketchup Memory Use

Hi everybody :slight_smile:
Just want to let the users of Sketchup know that, when a project reaches a certain size, that Sketchup will slow down and act erratically. So keep your projects fairly small.

                                                                  Gary Stanullwich

Vague and of no help Gary.

What size in relation (%) to your system memory, and swap file size ?

A slow down is expected with any application. As used memory approaches available memory, Windows must swap more memory back and forth from the swap file on disk (storage.) So the speed of your storage device has an effect here.

What version of SketchUp ?
(Ie, Your profile does not say. It it listed in the Help > About dialog.)

Be more specific about “erratically”, please.

1 Like

DanRathbun :sunny:
Sorry about the lack of information. I’m running Windows 7 32-bit. Ram : 3Gb. As for the Page File…the Max size is 5341Mb, I currently have the Custom Size to 5000Mb. I’m using Sketchup 8. As for running erratically… for example…when I want to move an object, I click on M (shortcut for MOVE), then it take between 30-45 seconds for the action to take place. And, also, when I DO move an object, it’s hard to keep the MOVE on the same plane…(moving it horizontally…forward or backward). Then appearing to “jump” from one location to another. Sometimes it happens on the green plane. When I want to move an object to the right…taking 30-45 seconds for the action to take place…then it might “jump” across the screen to another location. I could click on EDIT/ UNDO , but then there is the delay before the action takes place.
Gary Stanullwich

Dan Rathbun :sunny:

               Question :   Could  "bloating"  cause slow downs ?  The reason I ask is.......I downloaded a few textures, put them into MY PICTURES folder. Then, I added them to MATERIALS in Sketchup 8.  Once there, I clicked on these textures, clicked SAVE AS, then added them to  C:/Program Files/ Google/Sketchup/ Materials / Wood (or TILES, etc....)  Could this "over adding " of textures cause bloating ?  In turn, cause Sketchup 8 to slow down ?    I've got other related questions, but...not to confuse the issue, I'll stop here.    Thanks
                                                                  Gary Stanullwich

Would you please stop misusing code blocks in the forum!

1 Like

Which is beyond end of life, no longer supported, and will receive no more updates.

Discussing any specific version 8 bugs is a waste of everyone’s time.

Please update your profile to reflect that you are running Windows 7 32-bit, and SketchUp Make version 8.

Basically your system is old and limited, and you are attempting to work beyond the limits of your hardware. On such a system, you should not expect to be able to run any more than one “heavy” application at a time. And this only in a limited fashion.

You should be modeling with textures off in Xray mode. You should be using layers to control visibility, and only have visible what you are actually working on. (Ie, make it easier on SketchUp.)
You should be modeling with a “fast” style settings.

There are many topic threads and blog articles about how to model faster and smarter.

Each application process is limited to 2GB, on your 32-bit system.

See this Microsoft page:
Memory Limits for Windows and Windows Server Releases

FYI: The Windows edition of SketchUp, began to be compiled with the /LARGEADDRESSAWARE linker option in SketchUp 8 Maintenance Release 1 and later.
The SketchUp Release Notes say only users on 64-bit machines, running a 64-bit edition of Windows, will see imporovements.
SketchUp Application Release Notes


I see this topic as a “Chicken Little” warning. :chicken: (“The sky is falling! The sky is falling!”)

It was a waste of my time. (And I’m not happy about that, am now muting this topic, and will no longer be responding.)

It is also a waste of anyone’s time who reads all this.