SketchUp Make 2017 suddenly can't import JPG and PNG, and other troubles

My installation of SketchUp Make 2017 suddenly is behaving badly. It no longer seems to be able to import images. They’re grayed out in the dialog box.

That’s not all, I recently imported a large amount of STL files into SU to check their scale before moving them to my slicer. I know the STLs are solids since they loaded into the slicer (ChiTuBox) perfectly, but when loading into SU, many of the faces were not closed. It was a mess. I set about closing them by hand (hours of work), but realized this is wrong and shouldn’t happen in the first place.

Rich Pioneer Parts.skp (4.8 MB

It no longer can run Podium, either V 2.5 or 2.6. It crashes immediately upon trying to render.

I’m running a M 2019 MacBook Pro 16". The program was running correctly until it wasn’t so i know that the initial load into the new Mac worked.

Someone suggested reloading the program, but Trimble no longer supports Make 2017. I have the original program on a separate drive and could reload it, but is there anything specific I need to do. I dread removing the program — which is now irreplaceable — only to find that I can’t reload it. I rely on SU a lot and, although there’s other programs out there I could use, I do not want to go up that learning curve. I’ve been using SU since V1.0 in the 1990s.

Any ideas? Is there some switch I clicked that made all this happen.

Don’t double post!

Ignoring replies and making new threads doesn’t help. Especially when when you can simply download and install a new version of 2017.

1 Like

Can I get a new version of 2017? If so, where?

The last version of SketchUp 2017 Make is available from sketchup.com/download/all

Just to be clear, nothing has changed with 2017 since it was last released, but I suspect things on your computer may have.

1 Like

I told you that in reply to the first time you posted this but it seems you’ve ignored that reply.

Never let reality get in the way of a rant.

1 Like

Mia culpa! I just did the new download and I still can’t import images. I just checked SU’s disk access and gave it full access to everything and still they’re grayed out. I’m not ranting. I’m just stuck.

Frankly, I had forgotten that I posted the question here. I thought it was on Podium’s forum. Sorry for the confusion.

I already tried to help you in a reply to your first post about this.

When you open the Import dialogue, what is the Format menu at the bottom set to?

Have you tried dragging and dropping image file into an open SketchUp window?

1 Like

And this is why we ask that you don’t double post. We have to chase around looking for all your questions and our answers.
It is also why we ask you to fill in your profile, which you seem to refuse to do, so we don’t have to keep asking all those relevant questions.

One can only have one version of SU Podium in a SketchUp installation, you need to uninstall the other one completely upon installing another.
2.6 doesn’t work with version 2017 anyway, no use in trying that route.
Why did you upgrade to 2.6?

As was noted more than once previously, by not filling in your forum profile you are making it harder than necessary for us to try to help. Those details often matter!

Edit: Also, it is best to start a new topic for each separable question instead of piling them all into one. Doing that makes it possible for others to find meaningful content by looking at the title of the topic. Who would have guessed from the title that this topic also noted issues with STL import and Podium

I’m not sure quite what the M in front of that means. Do you have an Intel-based 2019 MBP 16" or a new M1? What version of macOS are you running?

I have a 2019 Intel-based MBP 16" running macOS 11.6.1 Big Sur. I can run SketchUp Make 2017 on it and importing images works fine. I have found that 2017 is less stable on macOS 11 than I might like (crashes now and again for mysterious reasons), but it does run for me. So, there must be some detail of your setup that is different. I don’t have enough information to even guess what.

2 Likes

Perhaps a moderator could gather up the various threads and strings into one cohesive bunch to avoid more irrelevant, repetitive or unnecessary additions to the individual threads.

I just updated my profile. I had not intended to leave so much out. I am not running 2.6, and just found that it’s no good with Make 2017. I’m only trying to run version 2.5 and just loaded a fresh version of it, but that crashes SU as it did before. And again, I’m sorry that I ran multiple threads. I will restrict further interaction to this one only.

I think the problem may be upgrading the Mac to Monterey. That’s the only change that I made that could have caused all this trouble. And I have no idea how to remediate it.

This may indeed be your major issue! Changing operating systems is a bit like moving house. I have all this furniture but I can’t arrange it properly. Something that fits in one house may not in another. But it fits in Bob’s house so why not mine? Bob has an annex…

1 Like

If you have re-installed SketchUp Make, and confirmed that it has access to the files and folders under Preferences>Security and Privacy>Privacy, and restarted your computer?

I did not restart the computer after making all the changes. I will do that now. I’ve tried dragging and dropping, but it doesn’t work.

The format box says this…

Just solved that problem. The file type was shown as “JPEG”. SU didn’t recognize it. I changed all the types to “JPG” and voila, SU sees them.

Now I just have to deal with the Podium issue and we’re all set.

I am going to restart the computer.