Sketchup Layout Label Text in 2 or more lines

Hey there,
another question
I mainly work with dynamic components. I already have a bunch of them because the make my working life easier so far. But I have an issue with them…
In the first picture (

)you se the dynamic component in sketchup. It is a bolt with washers and Geka. It is used for connection of wood parts in wood construktion area…I can select several spezifications, and they are automatically assigned to the component name.
Then in layout i use the label tool and refer to the dynamicComponent(name). You see it in
After selection the text ist waaay too long and I mostly have to use A3 papers to display it in 8pt textsize. You see it in .
Is there a easy way to get referenced label text in at least 2 or 3 lines?
In doing so the reference should stay active because somtimes i have to alter the component data in sketchup…
In Picture 2 you see in the selectiion area that the “Name” field is displayed in 2 lines, why not transfer it like this to sketchup…mmmh. That would be fine, what do you think? / is ther in LO2020 an easy way to handle this?
Thanks spb

1 Like

Split the lines up with a newline character, a carriage return or both. It worked for me with just newlines on a Mac. You could try one or the other or both. CHAR(10) for newline and CHAR(13) for carriage return.

=concatenate("If you notice this notice",CHAR(10),"You will notice",CHAR(10),"That this notice",CHAR(10),"Is not worth noticing")


In Layout:




Hey McGordon,

I made this:

  1. Insert CHAR(10) in between my concatenate function
  2. Klick Sketchup save
  3. Actualize Model Reference in Layout
  4. The result was instantly as i wanted it

thank you so much for your help

If somone needs it here is the character table:



Note too that you can just grab the label text corner grip in LayOut and modify the label shape. The contents will word wrap accordingly.

Hey Anssi,
unfortunately not I Think. If you pick the lable text corner, the whole text inclusively the arrow (lable line) gets distorted. The text is shown in 2 or 3 lines but is not displayed fully anymore.
Here you got it:

And: The perassigned Place of the arrow moves. Thats not the result i can work with productively

Hoping I understood you right.


Is there a trick to this? I cannot get it to work. I often want multi-line leaders and I find that I always have to put in carriage returns to get a multi-line text box. I really wish I could just define the size of the text box and let LayOut take care of the word-wrapping.

You know that double clicking on the leader will enable you to resize the text box without the leader being affected…?

Then after you’re done click out and if necessary you can right click and size to fit

1 Like

In the trays to the right (generally) find “Text Style”, for automatically resized text boxes choose where you want it to anchor “Top”, and the second to last choice is “Unbounded” choose that and it will resize automatically.

Text style

I have mine set as align left, align top and unbounded as you can see.
Good luck.

1 Like