SketchUp keeps crashing when installing plugins

I’m using version 21.1.279. Is this the newest version?
I’m not getting bugsplats, just “plain” crashes. SketchUp doesn’t freeze - it just shuts down immediately.
When I reopen it, the plugin I tried to install is installed, so I assume that the crash happens only after plugin installation.
In my OpenGL preferences, I can see that my GTX 1070 is being used.
Box, how do I “work out what the issue is with my installation”? I followed the guidelines for what people call a proper SU installation, had no errors whatsoever.
This stuff is driving me insane. I can’t normally use SketchUp for like a week.

That’s very strange that it’ll just terminate like that. Have you tried temporarily removing installed extensions? Would be good to test, as if it doesn’t crash then when you install a new extension it might be an existing extension causing problems.

By “temporarily remove” you mean to delete or to disable?
I can try to disable them, but deleting would be a vicious cycle.
I started with installing extensions from trusted developers like you, Eneroth, Chris Fullmer, Fredo etc. and already experienced crashes, one after another.

Okay, I can see a new version, 21.1.299.
I have 21.1.279.
Do I have to reinstall SketchUp from scratch, or can somehow do a “patch” from the new installer?

Download and run the new installer.

It will overwrite the existing 2021 installation, since it is still a 2021 version and just a point update, not a new version. But it will prompt for confirmation first.

And AFAIK there isn’t a patch update.

1 Like

-2021-aug-31-011

I almost pinned a solution already, but my guts told me well that I shouldn’t trust SketchUp at all.
I installed the newest, newest SketchUp.
Now I’m getting this error while installing the most important plugin!

Edit: The plugin is working. I don’t know what the error means. Should I worry about the unknown future?

It’s the kind of internal Ruby error that can happen either on startup of a plug-in when a variable hasn’t been initialised, or at some other point when an error occurs that hasn’t been expected and checked for. If the plug-in is working in spite of the error, don’t worry about it.

But it would be worth reporting to Fredo on the SketchUcation plug-ins forum (SketchUcation.com/plug-in store)

1 Like

Thanks, John!
Looks like everything is working fine now :smiley:

Something to know about is that there is an issue with how SketchUp handles unicode. A path that includes \u is highly likely to have problems. I’m happy if things worked out ok in this case, but having ‘user’ as the user name is going to break some things. So would naming the file as ‘upstairs.skp’ for example.

Wow, I’m genuinely shocked. How can any software have problems with file paths starting with a specific letter? This is ridiculous. I mean, it’s good that you told it, but it has to be resolved. How can we be limited from using one of the alphabet letters?

Use uppercase “U”.
The error is not in SketchUp itself but the Ruby script language interpreter.

This applies even to operating systems. Both Windows and the MacOS have a list of characters that are forbidden in file and folder names.

Okay, so only lowercase “u” is restricted, right?
Any other letters are restricted?

AFAIK, yes, and only as the first character of a folder or file name. @colin speculated in another thread about lowercase “p” but I haven’t tested it.

1 Like

This sounds like SketchUp trying to interpret escape sequences in a string that already is Unicode. This should not be happening.

Has the “\u” been comfirmed to be the issue here?

Yes. The issue has existed probably ever since SketchUp started supporting Ruby. Dynamic Components, for instance, is suffering of it.

How do they suffer? You cannot make a dynamic component starting its name with uppercase “u”?

No, not the character “u”. He mentions \u - the slash there is key, that denotes an escaped character.

For instance, puts "\u00A9" will print the copyright symbol, 00A9 is the hexadecimal notation for that unicode code point.

I’m not seeing anything in this thread to indicate this is the source of this. Where did you get that from?

My impression was that installing a patch update fixed the crash. SketchUp keeps crashing when installing plugins - #10 by michal.p

The error from RoundCorner being a different issue by itself.

You’re right, maybe the topic should be split. But I dunno how to do this.

The slash is supplied by Windows. I just tried (iversion 2020 as it is my work computer). Renamed a model to start with lowercase u and this is what I get when trying to open Component Attributes:
image
Without the u it works as it should.

Lets keep that to a separate thread. This doesn’t appear to be related.

1 Like