Sketchup failed to open document error! Please help

Can someone please help! I’ve got multiple sketchup files which wont open at all. Everytime it says ‘failed to open document’, even upon trying the skp files. I’ve worked several months on this and i really need these files right now.

I had transfered (copied) the files from my pc to a usb drive, and i didnt not use the usb since then. (maybe 1 month). And now when im trying to open the files, the error pops up. I tried opening from the usb directly and tried copy pasting back into my laptop, then opening, but again nothing works.

I suspecting the files got corrupted due to the transfer to the usb… but i really need the files. They are worth monthss of work. Is there any way to save them??? @colin

one of the file is in this link with the skb file too.

I couldn’t get anything out of the files. I’ve asked a developer to take a look, but I’m not hopeful.

The developer was able to recover the components and materials in the file, but nothing in the scene. You should look at the Components tray and see if the components will let you rebuild the scene.