Sketchup Education Office365 SSO Login Bug

We had been using the Office365 version of Sketchup from the Windows Store for about a month before running into problems a few weeks back with users being unable to login.

We narrowed the cause of this problem down to the enabling of SSO within ADConnect on our Tenant.

It’s not feasible to disable SSO now, however one can proceed despite the problem (in most instances) by selecting ‘Use another account’ and re-signing in with the same credentials. Unfortunately this problem has, and continues to trip up Staff/Students.

One will also occasionally see some strange errors that stop the user proceeding at all as shown below:

image

Hi @JHI

Thanks for reaching out, and sorry that you’re having login issues.

Was SSO recently enabled? If not, it seems strange that everything was working fine for a month and all of a sudden issues started.

Either way, I think we can bypass these issues by adding you to the whitelist. Please send me your school’s domain and I’ll add you.

-Joy

I was overjoyed to see that SUfS had added MicroSoft sign on: we are in China - Google is not an option. However, I CANNOT get the MicroSoft sign on to appear :o I managed to get it eventually last week, but trying to plan for classes using it and it is virtually impossible now. A colleague managed it after following many of the different links etc, but it was a long and tortuous process and she cannot specify one particular action that enabled it. I went around the houses and even opened a case with MicroSoft before I managed to get in by using the ‘Start Modelling’ button from one of the original Tutorials. However, this doesn’t seem to be working, either. The only sign on option that appears is that for Google, now. (I see that there are many Tutorials, now - have these additions changed something in the background?)

If you can point me to a functioning link that my students can use to get SUfS to open a MicroSoft log-in option, I would be overjoyed! (And we can move forward with our Class Plans :slight_smile: )

Thanks!

Hi @MrGee

The Microsoft and Google login options should always appear for a first-time user at https://edu.sketchup.com/app. (Return users will either remain logged in from their previous session or will be prompted to re-log in with Microsoft or Google. This depends on if they logged out at their last session, and how long ago their last session was.)

Alternatively, you can use this url for Microsoft-only login: https://edu.sketchup.com/app?auth=msft

If you still do not see the option to log in with Microsoft, could you try 1) clearing your browser cache, 2) trying that url from an incognito browser, or 3) logging in from a browser that you have not previously used to access SketchUp for Schools.

Hi @joy,

Thanks for the link to @MrGee; that will be useful for MacOS users!

Azure SSO was recently enabled as part of a separate project and appears to have directly contributed to the issue at hand.

Domains are:
stac.school.nz
stacmail.net

Thanks for your time!

@JHI I added those domains to the whitelist. Give it a try now and let me know if the issues persist.

@joy unfortunately the errors still appear to be occurring in the app. Based on my last few tests with the link you provided above (which had no issues), this may be isolated to the Windows Store app.

image

@JHI same feedback as for @MrGee, could you try one of the following: 1) clear your cookies for SketchUp for Schools, 2) try accessing from an incognito browser, or 3) log in from a browser that you have not previously used to access SketchUp for Schools.

Clearing system cookies and browsing cache did not help, and the last two are not applicable; the problem is singularly with the application installed from the Windows Store. Browser-based access is fine.

Just checked with some Students: when we use the first of those links, it works fine :slight_smile:

(Just found a student who hadn’t followed the first link: the second link opens a Sign On window which only has the MicroSoft option (with a link below that to take them to a Google sign on), so that one is probably the most useful for us :smiley: )

I found that the links from the Videos on the webpage didn’t give the MicroSoft option; the basic App link (which was in the documentation) was how we got there before. The links from the MicroSoft Store are pretty useless - never work.

Great to know which links work, though: perhaps tidying up the others over time can be done.

Looking forward to using some of the lessons :smiley:

Thanks :slight_smile:

@JHI @MrGee

Thanks for updating the thread with your findings. We are looking into the issues with the Microsoft Store. In the meantime, please direct your users to access SketchUp for Schools at the links I provided.