SketchUp Doesn't Consider Component a Solid

Do a Google search for “Lamborghini V12 Engine”. There are some video and other stuff that should give clues as to how it should look. In just a few short minutes I was able to discover the V12 is actually two in-line 6 cyl engines slightly offset in a V configuration.

GOOD NEWS!! After trying it a few different ways and lots of patience and pressing of the “wait” button, it finally worked!! The two halves are now molded together inside one single component I will begin cutting the wacky geometry down the bottom of the half-line tomorrow.

I’ve checked out youtube a couple of times just to get some extra reference angles, engine rebuilds tend to be the most helpful because you don’t just see what is visible when the engine is in one piece. As for learning what a V12 really is, I learned all of that kinda stuff a long time ago by watching Top Gear and helping my dad in the shop. This kinda caused me to design the engine the way I did.


Sorry if it seems like I am beating this dead horse, but I have unfortunately had the same problem with a different component. I couldn’t find anything wrong with it but SketchUp still doesn’t like it. Could you guys help me out again?

Lamborghini V12 Engine (4).skp (11.7 MB)

There are two little flaps, one on each side.

Also a quick purge reduced it to 400ish kb instead of 11mb
Lamborghini V12 Engine Box.skp (459.0 KB)


Thank you for last week’s help I should have caught those. And I’m sorry, maybe I’m missing the point, maybe I’m just not seeing something, but I’ve done it again.
Lamborghini V12 Engine.skp (796.6 KB)
While I appreciate you guys helping me out I still don’t quite understand what I’m missing. I understand the ones where you can see the bold lines but I could not find any of those on this one. On top of this, I don’t understand how to find those super tiny triangles without Solid Inspector. Sure you could technically use the outline of the shape, but if the edges are small enough the blur of the highlight will cover up the gap. I appreciate all the help I can get and any advice for future situations.

Thank you in advance again.

The problem you seem to have is that you make things that have very tight curves and sharp corners. Looking at your model without using solid inspector I can see where the errors will most likely be, but they are so small they are basically impossible to fix without a lot of trial and error. Even solid inspector doesn’t fix everything, I hit it with a second extension that cleaned the rest.
There is also some stray geometry floating around.
Lamborghini V12 Engine(1)Box.skp (1.5 MB)

Just so you know, I imported your model into sketchup shop, the paid web version that has solid inspector, and it failed to fix it.
You are running into a version of the tiny face issue. when vertices get too close together SU often sees them as the same point, or goes the other way and adds extra faces in the same place.
The easiest way around this is to work at a larger scale, 100 times or even 1000 times larger. This allows faces to form correctly and would solve many of your issues.
I notice you are working with imperial units, surely a Lamborghini would be metric. If you were working in metric it would be simple to use meters as millimeters. But however you do it you’ll have more success at a larger size.
I scaled up you model by 100 and solid inspector fix it no problems.

Here is a link that explains it with a few demos and another option to avoid it. The Dave Method

OK, the dave method makes a lot of sense I used that just now to try to solve the model on my own. Basically, I figured out there was a lot of hidden geometry in places it shouldn’t be and once I cleaned that up the model was solid. For some reason, Sketchup really likes creating hidden geometry around the holes in a flat face, like on the back of the component, so I deleted that out.
Basically what I am hearing you say is that I might have better luck if I create slightly less complex models or if I use the dave method or both. This makes sense and I can see now what is causing Sketchup’s confusion.
As for the units I’m using I don’t really have a whole lot of precise information on what is supposed to be what size so it is kinda easier for me to just use imperial rather than trying to convert something simple like 1/8" to mm. For right now without a ton of concrete information I can easily type in the few precise metric units I have into the measurements window at the bottom right and it works pretty well. However, I can see what you are saying about how it would be easier when you go to scale things up because the metric system is in increments of ten.
Anyway, thank you again I will use the tips in the future, and hopefully, I will be more successful!

FWIW, when I want to make accurate models of small objects and they aren’t part of a larger model, as would be the case with something like drawer or door pulls, I model with Units set to Meters. I will treat inches as meters so for an edge that is supposed to be 1/8 in. long it goes in as 0.125 meters long. This makes it much easier to avoid the tiny face issue. As an example, these are m6x1 shoulder screws I modeled in SketchUp and they are solid components.

If the slicer software allows you to specify the units when you import the .stl, you don’t even need to scale down before exporting it.

Wow, I didn’t know slicers could do that. I would have thought it would take a meter and when you tell it to convert to imperial it would call it 3.28084 ft. How do you do that in the slicer? I could really use it in the future.
Also, I feel like I already know the answer, but I gotta ask because I might use it in the future as well: how did you create those spirals? And is there a way to create them without an extension?

An stl file has no units contained in it, just numbers. Suppose you create a file containing a cube 2m on a side and export it as stl. The file will contain a cube, but the size will just be stated as 2 - with no specified units. If you tell the slicer to use mm when it loads the file, it will take the data in the file to mean the cube is 2mm on a side. Most slicers have a default unit they assume if you don’t specify something different.


That makes sense now. At first I didn’t realize slicers worked that way I thought a model always came with native units, good to know.

Steve has answered regarding the .stl. As for the screw threads, I’ve done a tutorial on how I normally model them in the desktop version. It’s here on the forum some place. I do use extensions for that but it is possible to model them without extensions. I did the modeling for the cast iron pulleys, below entirely in SketchUp Shop. That included the 1-4-20 screw threads for the grub screw holes. It’s not terribly difficult but it is tedious compared to the way I normally do them.

Since SketchUp represents circles as polygons, you can leverage that to divide a single turn of the thread into short sections. Then you need to do the math to figure out how to draw the geometry.

If you want useful small threads in a 3D printed object, though, I would recommend modeling a slightly undersized hole and then add a metal threaded insert.

And if it isn’t highly stressed, you can tap the thread into the plastic of an undersized hole.

Good to know. Thank you all for your assistance I really appreciate the help and hopefully, I don’t run into the same problem again.

Wow! I didn’t realize that was a possibility thank you so much. That is definitely helpful.
Thank you again to everybody for your help.

FWIW, the example Brian linked to works but doesn’t yield correct thread profiles. It works well enough if you only need to represent screw threads. The method I used creates the correct thread profile.

What do you mean by correct thread profile? Not to be rude but I don’t understand, what is the thread profile, and what is wrong with it?

Screw threads have a profile or shape. There are different types of thread profiles. Here are a few examples. If you need to be able to be able use some commercially made threaded object with your model, you’ll want to use the proper thread profile and pitch.


1 Like